Email Reports Do Not Work? Look Here!


#1

Hi all,

It seems like I’ve been pounding my head against a wall all weekend on a problem that should not be that difficult at all to set up – Email backup results to a mailbox.

For a little background, I’ve got about 45 VMs running in a datacenter environment, and we’ve been evaluating Duplicati for a few months now. I’ve been using Duplicati-Monitoring (genius!) to monitor the status of backups, but now I have specific folks that want to get emails on their particular VMs backups. Buuuut I don’t want to show them all the backups, just the ones they are concerned with.

So, enter dupReport, which will let me query the backups mailbox and deliver an email to each group pertaining to their backups – all I have to do is word the subject line at the beginning with the group name. Between that and naming the backup job appropriately, everyone gets an email every night and everyone is happy.

Small problem, though… I could not get email to work. My email server is an internal Exchange 2016 server. The servers are in the relay group in Exchange, so they can send emails internally without real authentication. I can use blat or powershell to send emails all day long from these servers and using this exchange server, but for some reason, Duplicati emails won’t go through. So, off to the command line I go. Hours go by. I still can’t get email to work, even with the bare minimum settings (–send-mail-to and --send-mail-url). And this is frustrating. Very, very frustrating. When I run into a problem like this, generally I walk away from it for a few hours, do something else, come back, and take another swing at it. I’ve done that a lot this weekend, and I finally found the answer.

Duplicati is trying to use TLS by default when it connects to the server.

So, my --send-mail-url statement looks like this:

–send-mail-url=smtp://mail.domain.com:25

… but in the logs that the command line generates, the same line looks like this:

–send-mail-url=smtp://mail.domain.com:25?starttls=when-available

… I didn’t put that there. Why in the H-E-double-hockey-sticks is it trying to use TLS? So I modified my option to say this:

–send-mail-url=smtp://mail.domain.com:25?starttls=no

… BINGO. I now have emails flowing in. No idea why someone thought that telling it to use TLS by default was a good idea. As far as I can tell, I could not find a forum post similar to this one. So, if you can’t get email to work from your Duplicati jobs, try the above and see if it works for you.

Thanks all!


#2

Glad you got it working :slight_smile:

Many providers no longer support unencrypted SMTP for security reasons, so it’s kind of an edge case to have a server refusing to use starttls :sweat_smile: but of course for internal use it doesn’t always make sense


#3

Understood. Perhaps this is something that could be added to the documentation and / or in the help text provided with the --send-mail-url command for future versions?

For example, if I knew it was going to try TLS by default, I would have just included the “?starttls=no” as part of my SMTP URL.

Thanks, Everyone


Solution summary - use:
–send-mail-url=smtp://mail.domain.com:25?starttls=no


#4

Flagging your prev. post as the fix (and copied content from initial post) as can’t set original post as solution.

Let me know if you disagree.


#5

Totally good with that. Thanks, JonMikeIV!