Email notifications not working for larger backups

Hi, just to start i think duplicati is great but I am having a couple of issues making it a streamlined process. I currently have two large(ish) backups running one is about 50gb and another is around 200gb. Both of these do produce a couple of errors (file not accessible etc but not a concern) but I have done other test backups with errors and still receive the notification.

My current setup is as follows:- the duplicati backup is run on a linux machine (ubuntu) which sends the backup to an ftp linux machine (running vsftpd). This process works fine everything backs up. The linux machine running the backup also acts as an smtp server to send the emails through our exchange server - this works fine (after a lot of troubleshooting) but only small backups seem to actually send email notifications. Anything that has to run for hours
or even the incremental backups (that take a few minutes) for the large backups don’t send emails. Could someone enlighten me as to why this may be the case?

Thanks in advance!

Hi, it’s unlikely anything to do with Duplicati. Does your mail server have a message size limit and could that be stopping the emails? Have you tried adding the following to the advanced settings:


There’s nothing in the code that would prevent emails being sent out due to long running jobs or backup sizes, so the issue is probably with your mail server.

Hi, thanks for the help. From what i can see on our mail server nothing seems to be actually reaching it, there is no record of it on there. Other smaller test backups send notifications fine through this. Surely that would suggest that its duplicati not sending the notification?

I have tried -send-mail-level=all and it makes no difference.

Is there anyway I can check to see if a notification has even been sent for the backup?

You can use the “Commandline” option from the Advanced job settings and add the log-file option and log level which needs to be set to “Information”. It will run the job and send the output to the browser. Copy and paste the output (don’t forget to remove sensitive info such as passwords, destinations, etc).

Thanks again for the help. So I followed your instructions and I found the following error in the log.

Failed to send email with server: smtp://, message: The authentication or decryption has failed., retrying with smtp:// => The authentication or decryption has failed.
Failed to send email: System.IO.IOException: The authentication or decryption has failed.
--> System.IO.IOException: The authentication or decryption has failed.
--> Mono.Security.Protocol.Tls.TlsException: Invalid certificate received from server.
 => The authentication or decryption has failed.

I thought this was a bit odd tho because I tried a smaller test back up and recieved this.

    Remote backup verification completed
      Downloading file (909 bytes) ...
      Downloading file (3.43 KB) ...
      Downloading file (3.43 MB) ...
    Email sent successfully using server: smtp://

This doesnt seem to be making any sense to me, what is different about the other backups so they cant send an email notification?

It appears that SSL/TLS is not working. Are you sure your mail server has a valid SSL/TLS certificate? Are you using the appropriate SMTP string for your server and have you tried using the “Accept any SSL Certificate” advanced option?

The mail server URL should be:

A url for the SMTP server, e.g. smtp:// Multiple servers can be supplied in a prioritized list, separated with semicolon. If a server fails, the next server in the list is tried, until the message has been sent.
If no server is supplied, a DNS lookup is performed to find the first recipient’s MX record, and all SMTP servers are tried in their priority order until the message is sent.
To enable SMTP over SSL, use the format smtps:// To enable SMTP STARTTLS, use the format smtp:// or smtp:// If no port is specified, port 25 is used for non-ssl, and 465 for SSL connections. To force not to use STARTTLS use smtp://

It looks like your server URL uses a non-encrypted connection:

How did you go, has changing the settings work for you?

Hi thank you so much for the help! sorry I havent been at my desk since Friday. I tried out setting it to “smtp://” and it worked! Quite weird how I have only been having this issue with these particular backups but its working now so thank you very much!

No problem. Glad your issue is resolved.