Duplicati will not start correctly and icon in topline of screen is missing

My Duplicati starts on starting my Mac. Since a six week stop of my Mac Duplicati cannot be started. I have to reinstall it and than it starts and works fine. After I switch of my Mac I can delete the ‘old’ version and everything seems OK. Till I want to check the Backup-results. Then I have to to reinstall Duplicati again etc.
Since the six weeks stop the little icon (that tells me when something is wrong with the backing up) is gone. I cannot find a way to get that one back.
Maybe these two things are one problem??
I am a just user and no IT specialist.
What can I do? But keep is simple (nearly idiotproof … :wink:
Johan Hahn (Utrecht, Netherlands)


did you consider this post for example:

Hello and thanks for your suggestion! I’m just a simple user and have no experience with Terminal etc. So messing around there seems not appropriate for me. Meanwhile I guess that the problem comes from the fact that I did not react to a software install message referring to Python3 - had no idea what that meant. In that case I skip the message (could be some hacker …).
I am now installing the CommandLineTools (or something like that) as a dmg-file (what is safe for me :wink: . Bit it goes very slowly. I’ll see wether that works. Maybe ˜I’ll come back to you if I stuck somewhere.
Have a nice day, Johan Hahn (Utrecht, Netherlands)

Hi again,
This is what I see in Terminal, after I reinstaller The missing software and restarted the Mac:

Last login: Wed Jul 12 13:53:31 on console
johan@iMac-van-Johan ~ % /usr/bin/python3
Python 3.8.2 (default, Jun 8 2021, 11:59:35)
[Clang 12.0.5 (clang-1205.0.22.11)] on darwin
Type “help”, “copyright”, “credits” or “license” for more information.

import Foundation
Traceback (most recent call last):
File “”, line 1, in
ModuleNotFoundError: No module named ‘Foundation’
sudo pip3 install pyobjc
File “”, line 1
sudo pip3 install pyobjc
SyntaxError: invalid syntax
Traceback (most recent call last):
File “”, line 1, in
NameError: name ‘sudo’ is not defined
sudo pip3 install pyobjc
File “”, line 1
sudo pip3 install pyobjc
SyntaxError: invalid syntax
File “”, line 1
SyntaxError: invalid syntax

But Duplicati still does not really start nor is the little symbol in the top command line of my screen.
As a layman I cannot go much deeper. So is there anything simple I can do to get Duplicati running properly?

Thanks again,
Johan Hahn

getting the ‘Foundation’ error message is just confirming you have the problem, to fix it, you need to exit out of Python (enter Ctrl Z should do it) and return to the command line to enter ‘sudo pip3 install pyobjc’.
Like this:
johan@iMac-van-Johan ~ % sudo pip3 install pyobjc

OK. Thank you so far.
That looks like it worked: a lot of text streaming over the Terminal screen.
If I now enter Python3 I get information that suggest to me that Python3 is running.
But Dup;icati still does not do what it should do. It probably runs in the background but it will not start as an app and the little Icon is also still missing.
What can I do next?


Johan G. Hahn
Luzernevlinder 86
3544DK Utrecht

E: jghahn@xs4all.nl
W: http://be.net/johanhahn

After I restarted my Mac I could start Duplicati and it worked! But where I the little icon in the Top command line of my screen?
Can we fix that too?

If I remember correctly (I have only occasional access to a Mac only to test Duplicati), the icon is hidden depending on the context, that is, if Duplicati UI is displayed, the icon is hidden (I presume that it is not necessary then).

The little icon used to be there all the time after my Mac was started up. I could click it to start Duplicati (as far as I remember well; at least is was visible all the time). It used to show (it had an x) when something was wrong with the backing up process that ran in the background. I never ‘did something to get ot visible. It just was there and now it is gone …)

Hello and sorry for the late reply, I don’t have easy and fast access to a Mac. I think that you are using Catalina, if it’s the case it’s not really supported as said in the post I gave you a link to. Your best bet is to use previous beta in this case.