Duplicati Using up my disk space?


#1

Hi, I am just testing out Dupicati, making some small backups of local folders to a network drive. However, it appears as Duplicati first buffers everything on my local drive, taking up loads of space, before copying the backup to the network drive. Can this be?
Obviously this is not desired, and when doing full backups, this cannot work because i do not have enough space. Is there a buffer setting I am not seeing?

P.S. otherwise the program looks pretty sweet, props!


#2

Hello @Mushin and welcome to the forum!

There’s buffering, but the limits are so low that you wouldn’t likely notice unless you increased some sizes. Sometimes people hugely increase “Remote volume size” on step 5 of a job setup from the 50 MB default.

While 2.0.3.3 beta lacks user aids, 2.0.3.11 canary explains:

This option does not relate to your maximum backup or file size, nor does it affect deduplication rates. See this page before you change the remote volume size.

In addition to the above link which is on the size control, there are controls on the file count and behaviors.

asynchronous-upload-folder

asynchronous-upload-limit

synchronous-upload


#3

Hi @ts678,
thanks for the fast reply!


#4

Depending on what version you are using there was a bug (fixed in 2.0.3.8) that was causing temp files to not be cleaned up.


#5

Thanks for the reminder about 2.0.3.8 @JonMikelV , though we’ll have to find out what @Mushin is running, and maybe when that issue was introduced. Duplicati temp dup-xxxx files not being deleted suggests a 2.0.3.6 regression with a 2.0.3.8 fix, however there seems to be at least some issue in 2.0.3.11 (see my update there).