Duplicati stopped working, now get server connection lost message

$ inxi -Sxxx
System: Host: Lenovo-ideapad-530S-15IKB Kernel: 5.4.0-65-generic x86_64 bits: 64 compiler: gcc v: 9.3.0
Desktop: Cinnamon 4.8.6 wm: muffin 4.8.1 dm: LightDM 1.30.0 Distro: Linux Mint 20.1 Ulyssa base: Ubuntu 20.04 focal

$ mono --version
Mono JIT compiler version (Debian Wed Feb 26 23:23:50 UTC 2020)
Copyright © 2002-2014 Novell, Inc, Xamarin Inc and Contributors.
TLS: __thread
SIGSEGV: altstack
Notifications: epoll
Architecture: amd64
Disabled: none
Misc: softdebug
Interpreter: yes
LLVM: supported, not enabled.
Suspend: hybrid
GC: sgen (concurrent by default)

$ sudo systemctl status duplicati.service
● duplicati.service - Duplicati web-server
Loaded: loaded (/lib/systemd/system/duplicati.service; enabled; vendor preset: enabled)
Active: active (running) since Mon 2021-02-15 14:34:13 -03; 6min ago
Main PID: 1007 (mono)
Tasks: 13 (limit: 9198)
Memory: 63.9M
CGroup: /system.slice/duplicati.service
├─1007 DuplicatiServer /usr/lib/duplicati/Duplicati.Server.exe --webservice-interface=any --webservice-port=8200 --portable-mode
└─1165 /usr/bin/mono-sgen /usr/lib/duplicati/Duplicati.Server.exe --webservice-interface=any --webservice-port=8200 --portable-mode

Feb 15 14:34:13 Lenovo-ideapad-530S-15IKB systemd[1]: Started Duplicati web-server.

I used duplicati for a few weeks with an account on operationtulip-dot-com (webdav) and it worked great. I installed it from the downloaded duplicati_2.0.5.112-1_all.deb file. I exported my settings to a file named duplicati-sync-1-duplicati-config.json.aes in order to make reinstallation easier.

All of a sudden, a few days ago I started getting this message: “The connection to the server is lost, attempting again in 0:05 0:04 0:03 0:02 0:01 now” and the countdown just loops forever.

Now I can’t get rid of this message and duplicati no longer works. I uninstalled duplicati and removed all version stuff from my ~/.config/Duplicati directory. I restarted my machine and installed duplicati from a deb file downloaded from the duplicati web site. I followed the duplicati online manual instructions for a linux installation, finally running

$ sudo systemctl enable duplicati.service
$ sudo systemctl daemon-reload
$ sudo systemctl start duplicati.service
$ sudo systemctl status duplicati.service

before opening http://localhost:8200 in my browser, only to find that the problem persists.

I don’t know if this matters, but I also have a nextcloud instance under my operationtulip-dot-com account. All duplicati stuff goes into a separate directory, however. No problems with nextcloud; everything’s working great. Also, I’ve got a password set for duplicati.

I really don’t know what to do since I don’t know much about cloud storage. Any help would be greatly appreciated, especially if someone can tell me how to get around the server connection lost message appearing as soon as I point my browser to http://localhost:8200. Is there a way, perhaps using duplicati-cli, to return to the backup configuration I saved in duplicati-sync-1-duplicati-config.json.aes? Thanks.

Welcome to the forum @gonzo

Your browser probably has some sort of developer tools on its menu (or often F12 works).
There will probably be a Network display around. Can you see any action, e.g. by refresh?

This might help determine if the server is really down or the browser just thinks that it is…
Unfortunately, I’m not very familiar with the workings of the JavaScript the browser runs…

I suppose you can also run lsof -i :8200 to look for a LISTEN and any ESTABLISHED.

Is Duplicati service running as you? You can check the PID systemctl status is giving you.
Make sure it’s not ~root/.config/Duplicati you want to be cleaning out if you want new start.

After getting back in the GUI, you can import your saved backup configuration to a new job.

Does the stuck Duplicati seem to be doing anything, e.g. if you watch with top command?

Thanks for the quick reply.

Duplicati.Server.exe was running as root but not using any cpu time. There were more than a dozen processes running. Same for mono, but fewer processes. I moved /root/.config/Duplicati folder contents to trash as root.

I have uninstalled Duplicati and deleted everything on my machine that was a file or folder with duplicati in its name except for my saved config file duplicati-sync-1-duplicati-config.json.aes. I then went back to duplicati_2.0.5.112-1_all.deb for a fresh install. I got a first run scenario when I opened http://localhost:8200 in my browser and used my saved json config file to set up my old backup again. I used “run now” and accomplished a successful backup.

I waited for the next scheduled backup and it ran OK, even with Duplicati.Server.exe running as root. I normally use the Palemoon browser, but it gives me the server connection lost error. I switched to Firefox and bookmarked http://localhost:8200. In either case I have to temporarily allow localhost. I have no problem opening http://localhost:8200 with Firefox, even though Duplicati.Server.exe and mono-sgen are running as root.

Right now, it looks like everything is working just fine. I succeeded in restoring a file from the operationtulip-dot-com server to a different local directory. I’ll wait a couple more days and try various other things before I mark my post as solved.

Thanks again @ts678!