Duplicati stays paused after waking from sleep

Environment:

  • Windows 10 1809
  • Duplicati version 2.0.4.23_beta_2019-07-14 or previous beta version
  • Running as a user program, not as a service
  • Started via task scheduler at login
  • Set to pause 30 sec after startup or hibernation, also tried zero
  • Simple setup with one backup job. No advanced options set under Settings.

Symptoms:

  • After rebooting or waking from hibernation, Duplicati runs as expected
  • After waking from sleep, Duplicati remains paused indefinitely. If I manually unpause, then it runs as expected.This is strictly repeatable.

I updated from the previous beta to the latest one using the windows installer to see if a reinstall would make any difference, but it didn’t.

Is anyone else seeing this behavior?

I’m not (Windows 10 1809, Duplicati 2.0.4.5 beta, launched from Desktop).

While paused, is it giving a Resume forecast in About --> System info e.g.:

estimatedPauseEnd : 2019-07-31T17:29:45.1561648-04:00
activeTask :
programState : Paused

which changes to below when on schedule:

estimatedPauseEnd : 0001-01-01T00:00:00
activeTask :
programState : Running

I’m watching it in a Chrome window. I don’t know if somehow the browser (or lack thereof) might matter.
I don’t know if Task Scheduler may be involved in any way. Have you tested any other startup methods?

Thank you. I tried manual startup (launched from the Start menu shortcut) and it behaves the same.

After program is first launched:
estimatedPauseEnd : 0001-01-01T00:00:00
activeTask :
programState : Running

After going to sleep and waking back up:
estimatedPauseEnd : 0001-01-01T00:00:00
activeTask :
programState : Paused

I also did an uninstall and reinstall, but that didn’t change the behavior either.

Could you run Event Viewer after sleep of a few minutes, to see if System log has entries like below?

Information 7/31/2019 7:53:08 PM Kernel-Power 187 (243)
User-mode process attempted to change the system state by calling SetSuspendState or SetSystemPowerState APIs.

Information 7/31/2019 7:53:12 PM Kernel-Power 42 (64)
The system is entering sleep.

Information 7/31/2019 7:53:16 PM Kernel-Power 107 (102)
The system has resumed from sleep.

Information 7/31/2019 7:55:48 PM Kernel-General 1 (5)
The system time has changed to ‎2019‎-‎07‎-‎31T23:55:48.500000000Z from ‎2019‎-‎07‎-‎31T23:53:16.598839600Z.

Information 7/31/2019 7:55:49 PM Kernel-Power 131 (33)
Firmware S3 times. ResumeCount: 1, FullResume: 270, AverageResume: 270

Windows looks like it’s supposed to announce power changes, then .NET Framework tells Duplicati.
Symptom acts like code never heard about a Resume. It goes into that pause with old date at Sleep.

Thank you ts678.

I do see those system event log entries. Nothing looks wrong there, although my Firmware S3 times are always zero.

I am running on a laptop, often with external keyboard and mouse.

I discovered that the issue depends on how the machine is woken up. If I wake using the power button, then Duplicati always resumes as expected. If I wake from an attached USB device, the behavior seems to depend on the device. For example.

  • Microsoft keyboard: Does not resume
  • Logitech wireless mouse: Does not resume
  • Dell simple keyboard: Does not resume
  • Dell wired mouse: Resumes as expected
  • Dell multimedia keyboard: Resumes as expected

The behavior seems to be strictly repeatable for each device. The system event log entries look the same for all devices, except for the wakeup source, which is “USB Composite Device” for any of the USB devices, or “Power button” if I wake using the power button.

I uninstalled the Microsoft Keyboard and Mouse Center software to see if that had any effect, but it did not.

Any ideas on how to troubleshoot further?

For Duplicati-specific troubleshooting, you could breakpoint a debugger at the code I cited to see what happens. Possibly something odd is happening such as the wake showing up first somehow, then the sleep showing up. I’m not sure how far before sleep the notification happens, and time doesn’t pass in actual sleep from the perception of the program, so for its processing the events may seem very near.

In more general advice (but the Internet has more than I do…), here are some other things you can try:

In Windows Settings, search for Troubleshoot. The entry for Power may be useful. Others may be too.

Powercfg command-line options have some options that may help, and also gives ideas about configs.

Windows Settings --> Power & Config --> Additional power settings --> Change plan settings --> Change advanced power settings has a GUI display of things you can try changing, but keep records, just in case.

Display all power related events (turn-on/-off/sleep/hibernate/…)? offers some ideas on monitoring events although some of it reminds me of your manual work. Still, tools might give some helpful interpretations…

How to Fix Windows 10 Sleep Mode Issues is one of probably many Internet articles on that general topic.

Power Management is a lot of technical information on how this works. Heavy reading, but may help here.

If you code, you could possibly write something either to that API or another that would help diagnose this. Ideally there’d be some easy method to monitor notifications at different levels, but I haven’t found one yet.

Good luck!

The problem has magically resolved itself recently. I haven’t changed anything with the Duplicati installation or config. Maybe it was resolved by a Windows update, not sure. I’m on Windows 10 1903 now.

1 Like