Duplicati starts immediately after hibernation

I set Duplicati “Pause after startup or hibernation” to 5 minutes. Missed scheduled backups shall be performed after this time. After power off this works fine, but after hibernation Duplicati immediately starts backups.
Do I have to set anything else so that Dupliati waits 5 minutes after hibernation too?

I think, this is a bug in Duplicati. I reported this in Github.

“Pause after startup or hibernation” does not work #4606 with missing information. Any luck with below?

  • I have searched open and closed issues for duplicates.
  • I have searched the forum for related topics.

and from past forum posts, I guess OS is Windows?

FWIW this works for me on Windows 10 21H1. A quick search (please search further) found the reverse, meaning lack of jobs starting rather than jobs starting without the requested pause time. Technical details:

Scheduled backups not starting after wake from sleep

also see

Wake up time after starting suspended computer and other references for attempts to debug the mystery.
Personally, I wonder if it will have to get some debug log messages added to Canary to help track it down.

Yes, I searched forum and Github, but maybe my search skill is not good enough to find relevant answers.

I use Win10 x64 21H1 19043.1237 too.

These seem to be different scenarios.

However Github “Pause after startup or hibernation” does not work #3693 describes the problem I have.

It´s not a big problem, but it would help me, if it worked.

I did not see any related problem in my log files.

That’s why they were “technical details” and “also see”, some of which still apply to debug or repairs.
Some things may be impossible to do without custom Windows programs, but some you can try are:

and I might as well ask whether this is just on hibernation, or if sleep will also wake up (faster) running.

except that’s Linux, and your issue didn’t say what you use, but I fixed that, and also asked about Linux.
The code that I showed in the topics I pointed to is deeply tied to Windows. I don’t know what Linux has.
The person who handled your issue has Linux I think, so maybe we will hear if #3693 is very different…

That’s good to know, but I wonder if logging needs to be put in the Windows event handler to see it work:

If logging is added, it would show up in the next Canary release. These are the latest code, meaning that possibility of new bugs exists (along with new fixes). If you have a less critical Windows system you can test it there. For that matter, is there another Windows system around that you can test current Beta on?

There might be some sort of rare (evidence is lack of reports) system-dependent issue going on here…

Just one remark:
I´m talking of Hibernation mode, the code above seems to point to Suspend mode.
I don´t know, whether this makes a difference while evaluating the problem.

Restart time of my computer from Hibernation is about 10 seconds. Of course restart time from Suspend mode is even faster, but I don´t care about this.

In the moment I use Duplicati 2.0.6.3_beta_2021-06-17. I have no problem to test a more current beta version - v2.0.6.100-2.0.6.100_canary_2021-08-11 e.g. or a totally different version. Since I do backups additionally with other methods, it would be not a very big problem if Duplicati fails.
But I´d need a detailed description on what to do and how to retrieve log files.

Btw.: I get e-mail notifications from Github, but not from this forum.

I think they’re supposed to be (and generally are) rolled together into a generic Suspend/Resume
Refer to PowerModes Enum at Docs / .NET / .NET API browser / Microsoft.Win32 / PowerModes
System Power States shows some of the underlying complexity, which is largely simplified away.

Here’s what the system I’m on now allows. Documentation is at Powercfg command-line options:

C:\>powercfg /availablesleepstates
The following sleep states are available on this system:
    Standby (S3)
    Hibernate
    Hybrid Sleep
    Fast Startup

The following sleep states are not available on this system:
    Standby (S1)
        The system firmware does not support this standby state.

    Standby (S2)
        The system firmware does not support this standby state.

    Standby (S0 Low Power Idle)
        The system firmware does not support this standby state.

What does yours support, and if you powercfg /sleepstudy, do your Hibernate and Sleep seem OK?

image

Is Suspend mode done by Start → Power → Sleep? What does Duplicati do about pause on this wake?

Thanks for being willing to test a Canary. Would that use a different computer? It also needs a developer adding some debug logging to see what’s going on, but we seem to be left without that for the moment…

You can certainly attempt to attach a debugger to Duplicati, but that’s an advanced skill that’s a lot to ask.
For above reasons, I’m trying to gather some general information using the easier-to-use Microsoft tools.

Here´s mine:

Die folgenden Standbymodusfunktionen sind auf diesem System verfgbar:
Standby (S0 Niedriger Energiestand - Leerlauf) Netzwerk verbunden
Ruhezustand

Die folgenden Standbymodusfunktionen sind auf diesem System nicht verfgbar:
Standby (S1)
Die Systemfirmware untersttzt diesen Standbystatus nicht.
Dieser Standbystatus ist deaktiviert, wenn der energiesparende S0-Leerlauf untersttzt wird.

Standby (S2)
Die Systemfirmware untersttzt diesen Standbystatus nicht.
Dieser Standbystatus ist deaktiviert, wenn der energiesparende S0-Leerlauf untersttzt wird.

Standby (S3)
Dieser Standbystatus ist deaktiviert, wenn der energiesparende S0-Leerlauf untersttzt wird.

Hybrider Standbymodus
Standby (S3) ist nicht verfgbar.

Schnellstart
Diese Aktion ist in der aktuellen Systemrichtlinie deaktiviert.

Hibernate is ok (no problems shown at all), I didn´t use Sleep mode in the past 4 days, so there is no report for Sleep.
I don´t know, how to insert a picture here, so it´s difficult to document my sleepstudy report.

My laptop computer is set to go to Hibernation when I close the laptop lid, and that´s what I do to end my computer session (a couple of times a day).

I don´t know exactly what you mean - Duplicati is set to make backups every 12 hours - at 1:00 pm and 1:00 am. Mostly my computer is in hibernation mode at 1:00 am, so Duplicati starts a backup when I open laptop lid in the morning. Duplicati backups take less than 2 minutes. They should be delayed 5 minutes after I open computer lid, but they start already about 2 minutes after opening lid. I tried to set 10 or 30 minutes for “Pause after startup or hibernation”, there was no influence on the behaviour of Duplicati. When my computer is on, Duplicati starts backups at the set times.

Google Translate says the PC has just this, which mine lacks:

The following standby features are available on this system:
Standby (S0 low energy level - idle) Network connected
Hibernation

What is Modern Standby probably applies to your Windows 10.

One can paste screenshots, but I didn’t really ask for the whole thing. Post it if you like though.

I guess it’s Network connected Hibernation, using /availablesleepstates. terminology.

When you use it, does Duplicati pause when system wakes (as opposed to when you Hibernate it)?
An old-style computer distinguishes between Sleep and Hibernate in places, e.g. try Start → Power:

image

Hibernate option may have to be specifically enabled. An old-style computer saves its memory to disk which means resuming operations is slow. Sleep would rely on keeping memory alive during its sleep.

Modern Standby vs S3 talks about some of the differences between the old and new ways. More later.

Your computer providing just (S0 low energy level - idle) Network connected Hibernation makes me wonder what your menu has. If it has both, I wonder how two map to one underlying mode.

Regardless of that, the underlying issue causing Duplicati not to pause on resume might be because computer never left Working state (S0) but only went into Sleep state (Modern Standby) described as

S0 low-power idle mode of the working state

Background activity while the system is “off” might describe your system. It was never “off” at the time.

the system is still in S0 (a fully running state, ready and able to do work).

C# WPF PowerModeChanged doesn’t work on Surface describes the problem. Possibly Duplicati was never informed of the power mode change (no logging, so can’t say), thus did not know to enter pause.

My laptop doesn´t have “Modern Standby” capabilities. This is available only in combination with built in mobile phone hardware. I don´t have this.

I did another test right now. I switched my computer off (Power Off) and on again. Immediately after getting full functionallity (all Autostart programs running) I started a Duplicati backup and got a warning “Server is currently paused, do you want to resume now?”.
I do not get this warning after Hibernation. I think, this means Duplicati server is already running after Hibernation. Duplicati should be paused, when I bring my laptop into Hibernation state.

This is still available in most current computers, my power menu looks exactly like yours (in German language of course). My laptop is a Dell Precision 17-7750, half a year old.

Got a citation for the “available only” part? I haven’t found that yet, and I do see:

Verifying if a system is Modern Standby capable and your powercfg output says exactly what’s seen there.

https://www.dell.com/en-us/work/shop/dell-laptops-and-notebooks/precision-7750-workstation/spd/precision-17-7750-laptop talks about Modern Standby in the Dell Precision 17-7750. What’s that say?
There are no configurations on the page with mobile phone hardware that I see, but I’m not a Dell expert…

EDIT:

I’m not an Intel expert, but in “Core i#” series, this was in some 4th generation Haswell products, it seems.

Intel’s Haswell Architecture Analyzed: Building a New PC and a New Intel
The Haswell Ultrabook Review: Core i7-4500U Tested

When I execute powercfg /a I get:

The following sleep states are available on this system:
Standby (S0 Low Power Idle) Network Connected

Network conntected indeed relates to “modern standby”. I didn´t know this (or notice this) so far.
This means, Duplicati cannot handle this modern standby up to now. Ok, that´s how it is.

For Intel processors you have to look at the figures after “Core i#” - my computer has built in an Intel Core i7-10850H. -10850H means a mobile CPU of 10th generation Comet Lake series.

Seemingly the same as the /availablestates run that we discussed. They’re synonyms:

  /AVAILABLESLEEPSTATES, /A
                     Reports the sleep states available on the system.

We don’t know positively that there’s not some way, but I’m seeing way too many Internet questions
about code that stopping working on Windows 8 connected standby, which became modern standy.

Duplicati is written in C#, whose code runs under .NET Framework (for the most part) on Windows.
.NET Framework is stagnant these days, so if this is its limitation, it may never be fixed by Microsoft.
There is a chance that the replacements .NET 5 or .NET 6 or later will provide better support for this.

If a current developer is willing to add debug logging, then we can at least see if Duplicati ever hears.
It would be best if someone with a similar system can test. I’m amazed that this issue is so unusual.

I don’t know how widespread this technology is, but the Anandtech article mentions it in Moorestown.
That was an Intel Atom processor announced in 2010, and it was a system-on-a-chip for mobile use.

My use of the Core i# term (maybe could have just used Core) meant Intel Core (microarchitecture)
which are the more powerful (and more power-consuming) lines that a normal laptop might have in it.

If there are any Windows developers (or C# developers for that matter) willing to volunteer, please do.
There may be a need for test code to look at how it works, instead of guessing from conflicting posts.

@ts678,
thank you again for all your answers.
Duplicati is great and I hope, it´s getting develloped further.