Duplicati service on Ubuntu 18.04 headless

I have found this post. I have added --webservice-listen-interface=any to my /lib/systemd/system/duplicati.service to make this service to listen on all IPs, but it still listens only on
Has this setting been deprecated?

Is the ssh tunnel currently the only solution for accessing Duplicati remotely? It works for me but I would prefer to have a normal access to IP:port if it is possible, of course.

It should work. Have you checked open ports to make sure the service is listening as expected?

Are you running a firewall?

Are there any other processes e posed from that box?

In this post I have found the next settings:

duplicati-server --webservice-interface=any --webservice-port=8200 --webservice-allowed-hostnames=*

It works now.

But in my case, I am on AWS EC2, so I decided to go with Nginx reverse proxy (https). It woks even with the Duplicati web service bound to the localhost. (ssh tunnel works too).

1 Like

Glad to hear you got it working!

I haven’t used nginx myself but it does seem to get popular.

BTW, it might be off topic, using Mono repository from here caused some instillation and especially upgrade headaches on my AWS EC2 Ubuntu 18.04. My instances stopped responding, a lot of dependencies issues , like:
Errors were encountered while processing: mono-devel
dependency problems - leaving unconfigured

Which were fixed by running:
dpkg --configure -a
apt install -f
apt dist-upgrade -y

again and again …

Doesn’t look good to me, especially, considering that these are cloud vms.

So probably I will replace it with the mono-devel from Ubuntu repository. At least it is already pre-compiled.


Ubuntu 18.04 mono package version 4.6.2, current Mono project 5.18.0. It looks like Ubuntu package is stale. But it works with Duplicati - and it doesn’t kill my ec2’s. I have heard about Mono packages upgrade issues on Ubuntu. I hardly will be using Mono on those machines for anything else than Duplicati, so I will stay with the old but tested option.