Duplicati Service Not Responding to Remote Management Port


I’m building out a new machine and installing Duplicati on it. I installed the Windows .exe and it worked great. Password and remote access was up in no time. I rememeber I needed to make a service and ran the command to w/out lcosing the TrayGUI – so it came up as 8300. As this is a new build I wanted it on 8200. So I removed Duplicati from windows and deleted the service. Reinstalled duplicati and reinstalled the service and removed the TrayGUI startup. It now runs on localhost:8200 but even after enabling remote access, adding the host name, trying*, and trying direct IP – I can’t get the remote access to work. I turned off the firewall and tried 8300 again. Neither of which worked either.

What am I missing?

I have fixed it. I realized I could reinstalled the service and upon doing so it is working now.

Hello, glad you got it working! Note that reinstalling is not needed to change the binding port. Duplicati automatically binds to 8200 on startup. If that port is already claimed, it tries 8300 and so on.

If you find Duplicati is running on 8300 it almost always means you have a second instance running.

If you use the Windows Service, you’ll want to adjust your TrayIcon shortcut so it includes the --no-hosted-server parameter. Otherwise the TrayIcon process will start up another instance of the Duplicati engine.