Duplicati service does not automatically start in windows 10


#1

I a running windows 10 x64 1809
Duplicati in portable mode as a service.

I need to manually start the service every time I boot or reboot the system. I have set it to automatic.

I have observed this only in windows 10 windows server 2008r2 works normally.

Any idea how to fix this…


#2

Try setting it to “Automatic (Delayed)” recommended for any service that isn’t required during boot or needs other OS services to be running e.g. your Internet connection. I wish more developers used this service option.


#3

Duplicati service stops running
Windows Service fails to start #2717
offer some (rather technical) troubleshooting notes that might help. Or just try what @Taomyn suggests.


#4

I’ve been getting the same issue and as a work around created a scheduled task to start the service on system start up by using the command line with highest privileges “net start duplicati” but with a delay of 10 minutes, which is plenty long enough for the PC to have settled down. So far I’ve restarted around 1/2 dozen times (we’ve had the power company doing some maintenance) and each time this has worked.

Hope it may help another at least find a work around for the issue.