Duplicati on Windows Server

#1

Goodday everyone!

I’m stuck with a problem regarding Duplicati. I have installed the software on multiple Windows Remote Servers as the new back-up program. The problem is, when a user connects to the RDS they get a popup

Does anyone have an idea of how to disable this popup screen?

I hope to hear from somebody,

Kind Regards
Arnoud van der Schans

0 Likes

#2

In your screenshot I see a Duplicati instance listening on poort 8300, so probably every users gets his own Duplicati instance (Default listening port is 8200).

My guess is that there is a shortcut to Duplicati.GUI.TrayIcon.exe in %PROGRAMDATA%\Microsoft\Windows\Start Menu\Programs\StartUp (the common Startup folder in the Start Menu).
Remove the shortcut from this location and install Duplicati as a Windows Service.

1 Like

#3

Hi @arnoudvanderschans, welcome to the forum!

A few other users have reported this happening to them (not just in servers) but I’ve been unable to replicate it.

I don’t believe running the tray icon executable is supposed to open a browser window but as @kees-z mentioned, that might be what’s going on.

How is your tray icon set up - is it in every user’s individual Startup or just in the “Default User” (so applied to all users)?

0 Likes

#4

It occurs when Duplicati is installed with the start-up option enabled on a Windows Remote Desktop Services server. Each user profile configured on the server will start their own process of Duplicati. Best approach is to disable the start-up option at log-on and configure Duplicati either to run from a admin account (requires the admin account to be logged on all the time) or to run as a service.

0 Likes