Duplicati on Linux


#1

After yet another frustrated and pointless waste of time I again can’t get this software to work on Linux.

On Windows Duplicati is first class, its reliable and easy to configure.

However on linux its mostly a waste of time. On two systems now i cant get anywhere with it.
If I run it as a local user its useless as it wont backup samba and home shares.
If I run it headless I can’t get it to connect from a different PC on the network and thus I cant setup a backup.

Is there any other utilities that offer encrypted backup over ssh like Duplicati? Surely someone must be bright enough to be able to write some decent backup software for Linux that can be quickly installed?

Many thanks.


#2

I Have had another look and when I query the status of duplicati I get this;

root@bssrv2:/etc/systemd/system# systemctl status duplicati
● duplicati.service
Loaded: loaded (/etc/systemd/system/duplicati.service; bad; vendor preset: enabled)
Active: inactive (dead)

Nov 26 16:04:09 bssrv2 systemd[1]: /etc/systemd/system/duplicati.service:1: Missing ‘=’.
Nov 26 16:05:06 bssrv2 systemd[1]: /etc/systemd/system/duplicati.service:1: Missing ‘=’.
Nov 26 16:05:15 bssrv2 systemd[1]: /etc/systemd/system/duplicati.service:1: Assignment outside of section. Ignoring.
Nov 26 16:05:15 bssrv2 systemd[1]: /etc/systemd/system/duplicati.service:2: Assignment outside of section. Ignoring.
Nov 26 16:05:15 bssrv2 systemd[1]: /etc/systemd/system/duplicati.service:3: Assignment outside of section. Ignoring.
Nov 26 16:05:15 bssrv2 systemd[1]: /etc/systemd/system/duplicati.service:1: Missing ‘=’.
Nov 26 16:07:57 bssrv2 systemd[1]: /etc/systemd/system/duplicati.service:1: Assignment outside of section. Ignoring.
Nov 26 16:07:57 bssrv2 systemd[1]: /etc/systemd/system/duplicati.service:2: Assignment outside of section. Ignoring.
Nov 26 16:07:57 bssrv2 systemd[1]: /etc/systemd/system/duplicati.service:3: Assignment outside of section. Ignoring.
Nov 26 16:07:57 bssrv2 systemd[1]: /etc/systemd/system/duplicati.service:1: Missing ‘=’.
root@bssrv2:/etc/systemd/system#

I followed the install guide on the net for ubuntu. I’m runing 18.4 LTS on Zentyal 6.

If I run; lsof -i :8200 | grep LISTEN
I get no output

and if I type duplicati I get;
root@bssrv2:/etc/systemd/system# duplicati
Server has started and is listening on 0.0.0.0, port 8200

It doesn’t seem to bind to and particular IP or ethernet card.

Anyone got any Ideas?

Many thanks.
Frustrated Duplicati user.


#3

Incidently it launches fine from the desktop as a local user.


#4

I feel your pain. Duplicati desperately needs stable & beta versions on Linux, because upgrades break things way too frequently.

I, too, keep using Duplicati on Linux because there is no good GUI for http://duplicity.nongnu.org/ There’s
Apps/DejaDup - GNOME Wiki! but it’s horribly inadequate as it is inseparable from Gnome’s consumer-only back-end service.


#5

The systemd file appears to be broken, so Duplicati is never started. Could you provide the content of /etc/systemd/system/duplicati.service?


#6

This is a security feature and also present on Windows. But naturally fewer people want remote access to a Windows machine.

You need to start the service with --webservice-interface=any otherwise it will only listen to requests from 127.0.0.1. If you do enable outside access, make sure you lock down your network, as the webserver is not security hardened.

If at all possible I recommend you use SSH port forwarding instead, as that makes it harder to get access to the service.

Not sure why that is? Duplicati just looks at files and folders, so if the stuff is mounted with read access from the user it should work fine.


#7

I also have good experience exposing it through an nginx reverse proxy with IP restrictions on :slight_smile:


#8

Yeah don’t give up just yet, I have it running pretty successfully on Fedora and was also hit by the block of the GUI when they added the IP protection - I think future versions won’t enable it for upgrades to prevent being locked out on headless systems.

FYI - mine runs as root and this is my service file in case it helps:

[Unit]
Description=Duplicati Backup software

[Service]
ExecStart=/usr/bin/mono /usr/lib/duplicati/Duplicati.Server.exe --webservice-interface=any
Restart=on-failure
RestartSec=30

[Install]
WantedBy=multi-user.target

#9

Thanks for all your support and input guys. I don’t have remote access (putty) to that server ATM. However I am working on it. As soon as I have I will be able to test and report back.

I have also got a Nethserver test server which I am going to have a go with.


#10

I’ve been using Duplicati on Linux & Windows all the time, and mostly the operating system doesn’t make any difference. In both cases, I use CLI only.

That’s because configuring large number of systems with GUI is also huge waste of time, when you can just remotely configure all the required stuff using configuration manager from single administration point when using CLI.


#11

That sounds interesting from an enterprise management perspective. Would you mind sharing some info on how you approach this?


#12

I’m curious about this as well. Would you be able to share some details on how you’re performing the remote configuration from the command line?


#13

Yeah this worked for me - with the username removed after the RestartSec=30, it runs as root. By default though Duplicati puts it’s own username in there and it doesn’t run as root.