Duplicati not updating to duplicati-2.0.4.5_beta_2018-11-28


#1

I install Duplicati_2.0.3.3_beta_2018-04-02 on a Raspberry Pi 3. I’m trying to upgrade to 2.0.4.5_beta_2018-11-28 via web interface but I keep getting the below error:

Any ideas?


#2

Hi @jordan.chang, welcome to the forum!

It sounds to me like you might be low on disk space causing the download to only partially fetch the update files.

I’d suggest checking the drive(s) with your tmp and .config/Duplicati folders.


#3

Hi @JonMikelV,

I’ve changed the tempdir to point to an external storage that has a 1TB capacity but still i’m getting the same error.


#4

It could be a problem with the server, or with the download process, or the RPI.

Can you try to manually download the file?
(I just tried and had no issues).

If you have SSH access to the RPI you can try:

curl -O -vvv "https://updates.duplicati.com/beta/duplicati-2.0.4.5_beta_2018-11-28.zip" 

Then after the download, you can do:

ls -la duplicati-2.0.4.5_beta_2018-11-28.zip

And you should see the file has the correct size:

-rw-r--r--  1 rpi  rpi  15083673 25 Jan 09:46 duplicati-2.0.4.5_beta_2018-11-28.zip