Duplicati kills my internet connection

sorry for the dramatic title but ive been having this issue and never thought it could be duplicati, or any software for that matter, but its starting to look that way. every time i run a fresh duplicati backup of my home dir(2-3gb with my filters), to box.com, i literally kill my internet connection. its all wifi and wired devices. i have to power cycle the modem or router and sometimes both.

i figured it was just my router going bad because i plugged directly into my modem and didnt “kill” the connection so i went a purchased a brand new one and it doesnt make a difference. i only tested for it killing the connection completely while wired directly into the modem rather than noticing any connection drops, though.

for testing i setup an iperf3 client and server where i maxed out the upload for a duration of 5GB with no issues. i copied over a 5GB file via scp with no issues. these were both transfers to a remote vps, not on my LAN. no matter what, when i run a fresh new duplicati backup ill get connection drops and then it will kill the connection completely.

im not trying to bash duplicati in any way but after a week pulling my hair out in the asus firmware channel and talking with a few ppl i cant seem to figure it out. i know it doesnt seem logical that duplicati is the culprit but maybe someone here can help me out?

Very interesting problem!

There is no way software should kill your internet connection like this. At most Duplicati is exposing/triggering a bug in your router firmware. What model routers were the old and new ones?

If you are keeping the new router, maybe you will be willing to test third party firmware on the old router. Maybe DD-WRT, OpenWrt, or Tomato are available for that older model.

Alternatively, maybe you could try backing up using a different protocol, or to a different back end (just as a test).

they are both asus routers, 68U and the 86U. i have them both running the Asuswrt-Merlin firmware. i went back to a previous version on them to test that as well.

you mean backing up to something other than box.com? what do you mean protocol?

Maybe the models are too similar. If they are both running the same firmware, you may be bit by the same bug in both

Yeah, sorry… probably a different back end. Most back ends only support a single protocol but some may support more than one. (For example I can back up to my NAS using SFTP, WebDAV, or some other protocols…)

What Duplicati version? Newer Experimental and Canary do parallel uploads to try to make them faster:

C:\ProgramData\Duplicati\duplicati-2.0.4.28_canary_2019-09-05>Duplicati.CommandLine.exe help asynchronous-concurrent-upload-limit
  --asynchronous-concurrent-upload-limit (Integer): The number of concurrent
    uploads allowed
    When performing asynchronous uploads, the maximum number of concurrent
    uploads allowed. Set to zero to disable the limit.
    * default value: 4

C:\ProgramData\Duplicati\duplicati-2.0.4.28_canary_2019-09-05>

You could try lowering that (if applicable), or try raising concurrency on iperf3, for example with -P option:

iPerf 3 user documentation

-P, --parallel n The number of simultaneous connections to make to the server. Default is 1.

Some scp/sftp programs also do concurent uploads. It wasn’t clear what your scp upload test was using:

Connections (Cyberduck program)

You can choose to use a single or multiple connections for file transfers.

Non Backend Flags (rclone program)

–transfers int Number of file transfers to run in parallel. (default 4)

Are you running with default 50 MB remote volume size, and with encryption (i.e. not ordinary .zip files)? Although I can’t find the evidence, ASUS Trend Micro deep packet inspection initially made me wonder if content scanning was going on in real time. It looks more like not, but details of DPI are extremely few…

Basically, if you have enhanced security (including ASUS Trend Micro AiProtection), try testing without it.

–throttle-upload or the throttle button near the top of the GUI page can try to limit upload speed, although because of bugs it sometimes limits download speed to the same level. Other bugs corrupt data, so you should use the latest canary if you want to try low speed throttles to see if you can keep your gear going.

Many routers also have throttle controls of their own, and at least mine seems to do a better job than the throttle Duplicati runs (which can get kind of bursty, and possibly high peak bursts are a factor in failure).

Watching the interface transfer rate in Windows Task Manager or whatever you have can show behavior.

When the connection fails, how does it fail? Is it Wi-Fi disconnects? Is reconnect to the router possible? How do connections from other devices (including phones and tablets on Wi-Fi) drop at the same time?

When Duplicati detects a drop via a break in the upload, it retries up to –number-of-retries times, and the attempts and error messages should be seen in server live log at About --> Show logs --> Live --> Retry however if you prefer –log-file at –log-file-log-level=Retry, that will do the job without you watching over it.

Does your ASUS software keep logs that might help? Some modems do. I know my cable modem does.