Duplicati failed to connect Amazone s3


I got below error while configuring connection Amazone s3:

Failed to connect: Invalid type System.Net.HttpWebRequest for instance field Amazon.Runtime.Internal.HttpRequest:_request

This is happened Ubuntu 16.04
Duplicati version :

Not able to create backup/restore with Amazone s3

That’s strange as a lot of other people have had no issues with S3.

However, a search of the forum for Amazon.Runtime.Internal.HttpRequest:_request seems to indicate other users have run into the issue with S3 COMPATIBLE destinations (such as Minio).

In at least one case, the solution was to set the --allowed-ssl-versions to TLS12 for the specific job (apparently it didn’t help when setting globally).

Can you try that out and see if it helps?

Thanks for reply back.

Somehow this was my software update issue in my system. ca-certificates-mono was not updated.

Below commands solved my issue

sudo apt get update
sudo apt-get install ca-certificates-mono

1 Like

Glad to hear you got it working!

The certificates issue with mono is not uncommon, though usually I think it has a different error attached to it or I might have suggested that fix sooner. :blush:

(Oh, I went ahead and your post as the solution in case others get the same error.)