Duplicati does not delete remote files on Strato WebDAV

Hi there,

I am using Duplicati server on a OMV (Debian). So far the backup works good but when I delete a backup and check that remote files should also be removed, the deletion takes very long time but the remote files are not getting removed. In the log I see this errors:

  1. Febr. 2018 16:27: Operation Delete with file duplicati-20180216T152258Z.dlist.zip.aes attempt 2 of 5 failed with message: GetResponse timed out

    {“ClassName”:“System.Net.WebException”,“Message”:“GetResponse timed out”,“InnerException”:{“ClassName”:“System.Net.WebException”,“Message”:“Aborted.”,“InnerException”:null,“HelpURL”:null,“StackTraceString”:" at System.Net.HttpWebRequest.EndGetResponse (IAsyncResult asyncResult) [0x00000] in :0 \n at Duplicati.Library.Utility.AsyncHttpRequest+AsyncWrapper.OnAsync (IAsyncResult r) [0x00000] in :0 “,“RemoteStackTraceString”:null,“RemoteStackIndex”:0,“HResult”:-2146233079,“Source”:“System”,“ExceptionMethod”:null,“Data”:null},“HelpURL”:null,“StackTraceString”:” at Duplicati.Library.Utility.AsyncHttpRequest+AsyncWrapper.GetResponseOrStream () [0x00000] in :0 \n at Duplicati.Library.Utility.AsyncHttpRequest.GetResponse () [0x00000] in :0 \n at Duplicati.Library.Backend.WEBDAV.Delete (System.String remotename) [0x00000] in :0 ",“RemoteStackTraceString”:null,“RemoteStackIndex”:0,“HResult”:-2146233079,“Source”:“Duplicati.Library.Utility”,“ExceptionMethod”:null,“Data”:null}

I am using a webdav target. Am I doing anything wrong?

Best regards,

Hi @Marius, welcome to the forum!

The GetResponse timed out message suggests your WebDAV target is taking longer than 10 seconds (the default Duplicati HTTP timeout) to respond to Dupicati’s request.

You didn’t mention what version of Duplicati you’re using, but if it’s a newer canary version then you could try setting the --http-operation-timeout to something longer than 10 seconds (the default).

http-operation-timeout (default 10 seconds)
This option changes the default timeout for any HTTP request, the time covers the entire operation from initial packet to shutdown

Hello @JonMikelV

Thank your for you reply. Sorry that I forgot to mention the version.
I am using the standard update channel, version

Why does Duplicati timeout when it should delete the files but does not timeout during the backup process?

I don’t think it’s Duplicati timing out, it’s the destination taking so long to reply.

Why your destination is happy with writes but not deletes I don’t know.

Does the job fail on the same file with every run? What happens if you rename or move the file so Duplicati thinks it’s already deleted?

In the meantime I changed the way how I back it up. I am using Strato HiDrive cloude storage which has pretty much of protocols. The way using WebDav directly by Duplicati does not work (other tools do not have problems with accessing HiDrive trough WebDav).

Now I am mounting the storage via SMB and OpenVPN connection to Strato. So I can chose the mountpoint in Duplicati which works very well.

Just for information, the job failed every run. Backing up is never a problem, deleting failed every run. If you dont think that it is a problem concerning Duplicati then I would not do anymore test.

Despite that, thank you very much for your answers. :slight_smile:

I’m glad you found a solution!

I know there are other users who have actually turned TO WebDAV to solve their issues so I’m not sure where the failure is.

Hopefully another Strato user will see this and let us know how the provider works for them. :slight_smile:

For now I’ve updated the topic title reflect that this is about a Strato connection & flagged your post as the solution - please let me know if you disagree.

1 Like

For not I’ve updated the topic title reflect that this is about a Strato connection & flagged your post as the solution - please let me know if you disagree.

Thank you!