Duplicati docker container in OMV

Dear all

I wan’t to use Duplicati in openmediavault via the docker container found here Docker Hub

Has anyone tried this and succeeded? I’ve tried several times now without any luck, but I think it comes down to my limited knowledge of Docker.
I can run the container but can’t access the webui. I suspect that either I haven’t given the correct pathways or I should configure the network somehow.
I haven’t had any luck with the information I’ve found this far, so I hope someone here can help?

Thanks!

Hi @raev, welcome to the forum!

I use the Docker Hub container on my unRAID box - and it took me a few test installs for me to get it all going, so my guess is you just need a little Docker knowledge. :slight_smile:

Unfortunately, I don’t have Open Media Vault to test with - hopefully somebody else who does will stop by, but until then I’ll see what I can do.

Am I correct in assume you’re trying to connect to Duplicati from a machine OTHER than the one running OMV?

That’s correct!
Maybe this will help Duplicati plugin Suggestion - Plugins - openmediavault I also asked on the OMV forum, but got an explanation where a different container is used, and where another plugin is installed that’s not relevant for me. Either way, I couldn’t get it to work :slight_smile: But maybe the screenshots there can help you to figure out what I should do.

What do you have in you Docker setting for IP Address and Extra Parameters (specifically “-p”)?

Good question! As parameters I’ve set “-p 8200:8200”, but in the IP/network settings I’m a little lost. I’ve been using both the bridge and macvlan setting (honestly I don’t know which one I should be using), but I’m totally in the dark here.

Well I set up OMV in a VM last night, got the extras installed, and enabled Docker GUI but haven’t figured out how to get any further installing the Duplicati container.

What I want hoping to test was whether it not the OMV handled connecting to the container similar to unRAID or if the parameter to allow external connections (--webservice-interface=*) is needed to be added to Extra Parameters.

My GUESS is the latter.

Hi again!
Sorry for my late reply. I’ve tried to add the --webservice-interface= command, but still with no luck. It seems it isn’t that straight forward, as I hoped it would be.
So if anybody know how to set it up - advice would still be very appreciated!

@raev Did you ever get this setup? I have been using duplicati in a docker container on OMV for quite some time now and may be able to help you get setup.

I also got it to work a couple of weeks ago. I used the same configurations I tried before, only diffence is that now I’m running OMV on a NUC and before I used a RPI 2. So I guess the RPI simply couldn’t handle the Docker image, and that was the problem all along.