Duplicati-cli backup error


I am not sure if this is a bug or user error because I am new to Duplicati. I am running a backup with the following command using version (On another note, is this a solid version or should I be testing with another one?)

duplicati-cli backup b2://<bucketName> '/path-to-directory/' --b2-accountid '<acctID>' --b2-applicationkey '<appKey>'

When I run this I get the following error:

System.IO.IOException: The source folder /path-to-directory/<acctID> does not exist, aborting backup
  at Duplicati.Library.Main.Controller+<>c__DisplayClass16_0.<Backup>b__0 (Duplicati.Library.Main.BackupResults result) <0x7fa8a37178 + 0x00b6c> in <filename unknown>:0 
  at Duplicati.Library.Main.Controller.RunAction[T] (Duplicati.Library.Main.T result, System.String[]& paths, IFilter& filter, System.Action`1 method) <0x7fa9edd000 + 0x00173> in <filename unknown>:0 

So why is it adding the accountID to the path? Something seems very odd. Is this a bug or did I do something wrong?


In case it is not clear from my post, all of the data encapsulated in ‘<>’ are actual information from B2. I removed them from the post for security purposes, but you should assume that all of those include correct information from B2.

Duplicati uses --option=value , so you need to replace some spaces with = marks. Also, depending on your shell, you need to use double quotes instead of single quotes:

duplicati-cli backup "b2://<bucketName>" "/path-to-directory/" --b2-accountid="<acctID>" --b2-applicationkey="<appKey>"
1 Like


These instructions solved it and it is now working properly.

Thank you!