Duplicati blocked in PDF

Hello, for several days I have been having problems with backup copies, and Duplicati hangs when it is going to make copies of the PDFs, something like this has never happened to me, I have deleted the copies, the databases and I have I reconfigured everything from 0, but the problem persists, I have also set the Snapshot option to off, on and auto, and it doesn’t work either. Any ideas on this? Thank you very much in advance.

the copies of what ?

do you have installed Duplicati as a service ?

The first thing I’d try is to actually copy the offending PDF to another location to see if there is anything wrong in accessing it.

Hello, I have deleted the backup settings.
duplicati is as a service and the PDF can be accessed without problems, but if it is not this PDF, it will be another one, I do not understand what could be happening, until now everything was working for me without problems.

And it’s been 2 hours and it’s still stuck on the same document. In order to stop it, I have to stop the service and then finish the Duplicati.Server task.

you don’t say if it was by copying it as I advised, or if you just double clicked on it.
Try to copy and move the file. Also did you try to stop the real time antivirus ? reboot the computer ?

Exactly, I did everything you told me, apart from deactivating the antivirus and restarting the Server, that’s why I already contacted this forum, it’s already somewhat frustrating, but it’s not just this document, it also happens with others, but they are just the PDFs, isn’t there a way to ignore if any problem is detected?

What’s modifying PDFs in folder? Duplicati wouldn’t even be reading any unmodified files.

About → Show log → Live → Verbose should name a lot of files, and why they were read.

What other type/size files are in that folder, and how are they being modified (or are they)?

Sysinternals Process Monitor can even show you the file reading if you want to watch that.

Is D: a regular local drive, or something special? What sort of backup destination is used?

About → System info → Server state properties → lastPgEvent might have clues on block.

Hello, this is what appears to me in the live log, and as you can see, more than 14 hours have passed and duplicati is still blocked.

The disk is drive D, a server HDD, and the destination drive is OneDrive v2, but I have also tried Sharepoint v2 and I have the same problem.

how did you proceed for that ? Did you create a new job or did you replace the destination in the existing job ?
As a test, can you create a brand new job and add as a source only one of the PDF files that appears to fail, as destination a local directory ?

is this the same backup as previously posted? Something moved:

but you’re not showing file information. Did the below change too?


Have you seen enough to claim that it always stops at 0% in .pdf?
That seems like the kind of thing a virus scanner could be causing.

I think virus scanner generally just traps you and delays file access.
It intends to be transparent, but slow – doesn’t say delay is coming.
You could have tried watching for a delay at file open by doing this:

If it stops at random spots, that could be a backlog in your uploads.
This test (which was not done) was hoping to get file or upload info:

These tests (which were not done) was to see what else is in there:

Perhaps the folder activities are by somebody else? Even if so, can you see what’s changed?

The short Verbose log shows there are other files. My hope was that you would see that stuck
file go by, although either things moved or there’s too much delay and it’s scrolled off the page.

Was that the same actual destination files but just switching the method by which you access?
Sharepoint still being remote Microsoft cloud, and not something like a local Sharepoint store?

It’s too bad you didn’t check Server state properties, as it would have helped to rule out a
problem where the Microsoft service can stop responding, sometimes as long as this blockage.

It’s kind of a soft ban because Duplicati isn’t adequately respecting requests to delay future transfer.

The below was probably also an attempt to get Microsoft service (which might be upset) out of sight:

Right now we have some brief views from different times, of different things, with lots of missing data.
While that might be fixed, another approach is to start with a simple case then do more until it breaks.

That’s the idea, yes.