Duplicati asks for password in some system

I have been installing duplicati for many users and configuring backup jobs for them . But for some users when i open duplicati it asks for password in the browser, i dont remember giving any password while installing duplicati . How to remove that or what will be the default password.

Note : I tried giving Duplicati , DUPLICATI, duplicati as passwords, but it didnt work out .

That should just be the access to the user interface in Duplicati settings. Maybe the user did it?

Haven’t looked into wiping it out without the password but it could just be finding one of Duplicati’s user settings files and deleting it. However, if you uninstall Duplicati and remove all its leftover files it should work but I don’t know if on Windows it might use the registry for example so that might need to be cleansed of it.

Possibly one of the others know exactly where it puts it but that will be different depending on the OS.

If its not that then it must be some sort of browser thing. I don’t know what else it would be but can’t see why anything else would do that other than Duplicati’s access setting.

They certainly have the ability. It’s in Settings, and is kept in Duplicati-server.sqlite configuration database.


Then you’ve probably seen this screen on first use of the UI, which is a typical place to set up passwords:


If you let some users set up their own backup config, they might have chosen Yes and set up a password.
If you have to clear a password, that’s possible, but it would be good to check with the affected users first.
They can remove their password more easily than they added it. If they didn’t add it, that’s a different story.

Is this a duplicati.com install? Some third parties add passwords, but I don’t know why it’d be inconsistent.

Thanks .I m sure that the user didn’t do . I was the one who downloaded duplicati from the website and installed. It asked for password when I tried to open duplicati.app. I did the same thing for other users as well , there wasn’t an issue like this for others.

No , it didnt ask for anything like the screenshot and i m sure about that. Also could you help me , where to find the password settings so that i remove that or delete those files. Thanks in advance.

Does Duplicati ask if wanting to set one on first time use? I don’t remember. That’s the only other thing that makes sense to me here. But then I wouldn’t know why it didn’t ask on others.


1 Like

That isn’t expected, so the rest may not be either. What OS is this? Did it just go to home screen?

The duplicati.com website (or something in it)? Still trying to verify this wasn’t a third-party package.

sounds a little different from original:

Some users get asked sometime, and some didn’t? Are these installs done by you physically there?
You might be able to get some odd results if you somehow use the same browser for all systems…

Is this the first open, meaning there is no configuration or previous backup to worry about preserving?
Are you using the TrayIcon or typing the URL in? Regardless, try typing in
Also, try a hard refresh on the web browser. Typically this is Control-F5, although it varies somewhat.

Duplicati-server.sqlite is in ~/.config/Duplicati (Linux) or %USERPROFILE%\AppData\Local\Duplicati.
Linux ones can be inspected with sqlitebrowser if you have it. Windows ones are a bit obfuscated.

Deleting the file (if you’re sure there are no backups, which would use random-named .sqlite files)
would reset to original, and should cause the (missing) First run setup dialog, and create that file.

You can also try the –webservice-password option on a one-time start to clear an existing password.

The password required to access the webserver. This option is saved so you do not need to set it on each run. Setting an empty value disables the password.

Where you put this depends on your OS.

There are no backups , as i m trying to configure a new backup . Its a windows machine and duplicati is installed in C:/Program Files/Duplicati 2 . Could you please tell me , where should i execute the command .

It didnt go to home screen , it stayed in the browser itself asking for a password . I even tried opening from edge and firefox , it asked for password again .

How do you do this? Typing http://localhost:8200? Regardless, do you wind up at port 8200?

On Windows, you can quit the running Duplicati. Right-click on Duplicati Tray Icon and choose Quit.
This should stop you from getting to Duplicati (because it’s down), even if you type URL in browser.

Start Duplicati.GUI.TrayIcon.exe with --webservice-password= option at end of the line to clear the password that you got (somehow). You should now be able to access Duplicati without a password.

Do you have Duplicati start at login? If so, you can quit the new one, logout, and login again to see if password problem returns. It shouldn’t, but it also shouldn’t have been there immediately after install.

An alternative method because you have no backups is to cd C:\Users\you\AppData\Local\Duplicati.
Verify that there’s a Duplicati-server.sqlite and no other .sqlite files. Quit Duplicati, delete database,
start Duplicati. The Duplicati-server.sqlite file should reappear, and UI will give the First run setup.