Duplicati Amazon S3 - Failed to Connect: The specified bucket does not exist

Receiving the Failed to Connect: The specified bucket does not exist.

The bucket exists on AWS.

I have tested our information in Cloudberry and it didn’t have an issue finding the bucket.

Decided to run it without the connection testing passing and it gave the following email message. What do I need to fix? Any assistance would be appreciated.

Failed: The specified bucket does not exist
Details: Amazon.S3.AmazonS3Exception: The specified bucket does not exist —> Amazon.Runtime.Internal.HttpErrorResponseException: The remote server returned an error: (404) Not Found. —> System.Net.WebException: The remote server returned an error: (404) Not Found.
at System.Net.HttpWebRequest.GetResponse()
at Amazon.Runtime.Internal.HttpRequest.GetResponse()
— End of inner exception stack trace —
at Amazon.Runtime.Internal.HttpRequest.GetResponse()
at Amazon.Runtime.Internal.HttpHandler1.InvokeSync(IExecutionContext executionContext) at Amazon.Runtime.Internal.RedirectHandler.InvokeSync(IExecutionContext executionContext) at Amazon.Runtime.Internal.Unmarshaller.InvokeSync(IExecutionContext executionContext) at Amazon.S3.Internal.AmazonS3ResponseHandler.InvokeSync(IExecutionContext executionContext) at Amazon.Runtime.Internal.ErrorHandler.InvokeSync(IExecutionContext executionContext) --- End of inner exception stack trace --- at Duplicati.Library.Main.BackendManager.List() at Duplicati.Library.Main.Operation.FilelistProcessor.RemoteListAnalysis(BackendManager backend, Options options, LocalDatabase database, IBackendWriter log, String protectedfile) at Duplicati.Library.Main.Operation.FilelistProcessor.VerifyRemoteList(BackendManager backend, Options options, LocalDatabase database, IBackendWriter log, String protectedfile) at Duplicati.Library.Main.Operation.BackupHandler.PreBackupVerify(BackendManager backend, String protectedfile) at Duplicati.Library.Main.Operation.BackupHandler.Run(String[] sources, IFilter filter) at Duplicati.Library.Main.Controller.<>c__DisplayClass17_0.<Backup>b__0(BackupResults result) at Duplicati.Library.Main.Controller.RunAction[T](T result, String[]& paths, IFilter& filter, Action1 method

Just off the top of my head, are the region and storage class correct for what you are trying to access?

Also, Object storage seems to be very sensitive to the ‘Folder Path’ key in the destination settings. Try removing whatever you have in there, so it’s blank, and see if that will work.

I have tried it with every imaginable combination to get it to work. Still no luck. It is frustrating.

I guess I would say you should post your logs. Check it for any personal information before posting it.

I faced the same issue with Duplicati2 beta on Windows. What worked for me was to remove the AWS Access ID from the bucket name, which duplicati had prompted to prepend. I removed it to just test with only the bucket name, and it worked.

Can you elaborate on that? It has been a while since I used S3 with Duplicati, but I don’t recall it asking to prepend the bucket name with your Access ID. The Access ID goes into a different field entirely when configuring the Destination.

In any case, glad you figured out your issue. Welcome to the forum!

When I try to test the connection by supplying just the bucket name, it asks to prepend with the username, and asks whether it should prepend automatically. If I choose yes, then it prepends it with Access Key ID and the test connection does not work after that.

Whereas if I select no and leave it unchanged, the “Test Connection” works successfully.

FYI, I am using Duplicati -

Great - thanks for the screen shot! I’ll look into this some more. It definitely seems like incorrect behavior at first glance.

1 Like

I found a posting by @kenkendk which has some background info about why this is done:

Yes, AWS S3 bucket names need to be globally unique. But don’t you have to precreate a bucket in the S3 console? If so you already have chosen a name, and S3 enforces global uniqueness at that point.

Unless Duplicati has the ability to create buckets (not sure), it doesn’t make sense to me for it to do this prompt. If it does have the ability to create buckets, maybe it should first test for its existence. If it exists, use verbatim. If it doesn’t exist, then maybe displaying a prompt makes sense.

@kenkendk any other thoughts?

1 Like