Duplicati 2 Restore fails, Error 450

I tried to restore files from my backup, which is stored on my local NAS.
Restore works fine when I use Operations > Restore files.

But I fail however, when I try to simulate a restore on a different computer according to Duplicati 2 users manual chapter “restoring-files-if-your-duplicati-installation-is-lost”.

Following the instructions given I select “Restore from configuration” in Duplicati 2.
Then I import backup settings from the settings.json file, which I saved before.
When I click “Test connection” thereafter, I get an “Error 450”. So restore is not possible.

How can I solve this problem?

Hello and welcome!

I have a couple questions:

What protocol are you using to back up to your NAS?
Is the different computer at the same location as the main computer?

Protocol is FTP.

The different computer is at the same location as the main computer.
I get the same error when I try this procedure at the main computer.

FTP can be a finicky protocol. Can you try FTP Alternative and see if it works any better?

I copied these settings from Duplicati 1.3.4.
There these settings worked well, but of course there was no alternative way for restore (as far as I remember - I uninstalled Duplicati 1.3.4 already).
I have to check whether my NAS (QNAP TS101) supports different protocols.

Why does FTP work with “Restore files” but not with “Restore from configuration”? I believe, this is a bug in Duplicati.

I tested “FTP Alternative” in the meantime - unfortunately this does not work with my NAS.

Good question. It should work the same. My guess is that the settings json you saved previously has some differences from the current configuration. Can you try re-exporting your backup job to a new json file? Try “restore from configuration” against that new json file. If it works we can compare the two json files to see what changed.

I’m assuming settings.json isn’t the real file name, and that it’s not a 1.3.4 settings file.
1.3.4 was a very different program, and you don’t want to be mixing anything between.

Discrepancy with advanced options in “Restore from configuration” #2605 is one bug.
I can’t explain more than the issue does, and I don’t know if it explains your situation…

The original name of settings.json is Daten_NAS-duplicati-config.json.
This file was exported immediately before I tried to restore a folder from a backup. So there are no defferences to the current configuration.

Copying the settings from Duplicati 1.3.4 means, that I looked at the Dupli1.3.4 and wrote these settings (IP-Address, Server name, path on server similar but different folder name, user name, password) to the corresponding fields in Duplicati 2.0.

I´m going to check the link in ts678´s reply, but this will take a little while.
Remark: I did not set any Advanced Options in my backup settings.

Thanks for all answers so far!

By the way - email notification does not work. I don´t get an email upon a new reply - I have no idea, what to change in my profile settings.

I’m not an expert, but I think you get emailed if someone uses the reply button at bottom right of a post.

If they use the blue Reply button, you don’t get an email but it might show up in your profile count at the screen’s upper right corner, especially if someone quotes you. There might be other factors that enter.

1 Like

In the meantime I found a workaround as follows:
I connect my NAS as a local drive first and then use “Direct restore from backup files”.
With this I can restore my data from my local NAS to a computer different from the one, which I backed up my data.

By the way, restore of files stored in OneDrive cloud works without any problems on different computers. It´s ony FTP what causes problems.

So I´m happy for the moment.
Thank you again for all your answers.

I would suggest considering alternatives. On my NAS I use WebDAV without issue. SFTP may also be an option.