Duplicati will not start

I have had Duplicati running for a while just fine without any problems. Then last week there was a pop-up about a new version. I attempted to install, but it never got that far. It would go to downloading and usually fail and say that I need to install. Once it got all the way to the “Activate” phase but failed that too. Now Duplicate has stopped running and won’t restart.

I have tried uninstalling and reinstalling. Still not working. I have uninstalled, rebooted, and re-installed. Still not starting.

I am using: duplicati- for the installs.

If you’re using canary versions, can you try one of the more recent ones? That one is pretty old. I’ve had no issues with the one released just a few days ago.

Also, did your original installation have the 64-bit version too? I once accidentally installed the wrong version when I had the other one installed prior and it was troublesome to fix.

I think that worked! I downloaded the and installed it. It started up and I’m able to run my backups again. Hopefully it will continue to work. That version was very glitchy!

1 Like

Agreed, and even its release announcement had concerns due to the extent of its change. Although canary often benefits from accumulated fixes, sometimes new code adds new bugs, which get shaken out over time. What’s odd in your report is why you didn’t hear about more improvement releases, or was pop-up ignored?

Thanks for running canary. It helps when some people are willing to use sometimes bleeding-edge code. :wink: