Disk I/O error on Windows Server

I think Duplicati can’t backup files on a Volume with data deduplication service enabled on Windows Server 2012.
This is what i’m talking about: Introduction to Data Deduplication in Windows Server 2012 | Storage at Microsoft

I noticed this when i tried to backup a folder on D: (with that service enabled) to a local USB drive as destination. It finished way too fast and i noticed it skipped with error most of the files.
ExaminedFiles: 3114
OpenedFiles: 3114
AddedFiles: 3114
FilesWithError: 5748
The total files on that folder is 3114+5748.

I see some files in the log with this error.
Warnings: [ Failed to process path: D:\MYFOLDER\72A4D459.tmp => I/O error.,

On the same Windows Server, but on the E: drive (with the data de-dupe service disabled) the backup runs fine.

I tried with snapshop policy required and off, both give me error on all those files. Tried changing duplicati to run as a service and still errors. Tried another folder on the D drive, still errors.

I see some VSS errors on event viewer with ID 8194.
“Volume Shadow Copy Service error: Unexpected error querying for the IVssWriterCallback interface. hr = 0x80070005, Access Denied.
This is often caused by incorrect security settings in either the writer or requestor process.”

Is there a switch in the advanced settings for this?

If I google for this, it suggests another program is interfering:


If you know which writer is causing the problem, you can use --vss-exclude-writers=<writer-guid> to disable it for the VSS snapshot creation.

Yeah i tried some of that, the tip to make event ID 8194 go away works but the backup still fails without the VSS error logged.
I don’t run any McAfee software either and i disabled antivirus to test.

I strongly suspected it had something to do with Windows 2012 deduplication service since the backup was failing only on the drive i had it enabled. To confirm i unoptimized the drive, disabled the service and the backup ran just fine!

There is something in the way the deduplication service interacts with shadow copy or some other system calls that makes not only duplicati fail, i saw some weird behavior running ArqBackup too.

Good debugging and detective work!

Did you ever narrow down what was causing the VSS issue for Duplicati and ArqBackup?

Did you try running vssadmin list writers and checking “State” and “Last error” to see if any are not stable or had errors?

And just for fun, do you find anything interesting with vssadmin list shadows?

try to add “–symlink-policy=Follow”

It worked for me.