Disable updates

I have Duplicati installed as a service on several Windows 10 machines.
The first backup works well; but on some machines, the following backup is not performed. The service is stopped and I think it is because there is a Duplicati update that is asking for a response. Is it possible to disable updatesT

There’s no simple way to disable the auto update checker, but if you don’t want to update Duplicati using its built-in update mechanism then you can simply just not click the “update now” link (or whatever it says).

Personally I prefer to update manually by downloading the latest msi/deb/docker image.

Something else may be going on if you only get one backup. Sounds like it might actually be crashing (possibly) which is why the service is no longer running. What version of Duplicati are you using?