Disable Https for web gui?

Is there a way to disable https on the web gui? For the Windows service, when I click open on the tray icon, I get a not secure error and no means to continue like you normally would with a self signed certificate. Doesnt work in Vivaldi and Edge, I have to change the address to http for edge. Works in Firefox. I use Vivaldi as my default its a pain atm.

I can only offer you hope, not a solution. I, too, use Vivaldi and am running Duplicati as a service on Windows (also on a Synology NAS). For me, http on port 8200 works fine. But I also don’t use the tray icon; I just have a browser bookmark. How are you starting the tray icon? I ran across this discussion on the topic which may be helpful:

I dont really have to run the taskbar app but in vivaldi when I change the link to http is goes back to https. Im trying to remove and cache/cookies realted to it but it doesnt improve. :frowning:

Ah, ok. I had a vague memory of a setting in Vivaldi that could force trying https first. The version I’m running (5.3) does not have that explicit setting, but >=5.4 does. Check for this:

Vivaldi 5.4 from Settings > Address Bar > Security Features > Always use Secure Connection (HTTPS)

I did not investigate it, but it may be possible to make this a site specific setting, too, if you don’t want to give up this protection for all other sites.

Can you verify this issue doesn’t exist in a private page in Vivaldi? Sounds like your cache is lingering in your browser. I also downloaded a copy of Vivaldi and pulled up Duplicati on 8200 with no issues using HTTP.

Duplicati runs on HTTP and not on HTTPS after a default install.

Try CTRL+F5 to manually reload the page and tell your browser to fetch a new copy of the page.

Always use Secure Connection is unchecked already.

Yeah website specific I was hoping to find a setting. Does duplicati not have something in a config file that can be altered?

In private window.I am able to access it with http without it trying to redirect.

Choosing Vivaldi Essentials, Classic, or Fully Loaded when setting up Vivaldi will have, “Always Use Secure Connection” disabled.

It appear that you manually have to turn it on. Even with that option on I can still access “xyz.ddns.net:8200” and it just says the page doesn’t support HTTPS and kicks me back to HTTP. Login works and I can view all scheduled jobs.

Tested this in a fresh Windows 10 VM.

Might want to blow out your cache settings for Vivaldi and start fresh. I wiped the entire user folder for this testing. Probably not what you want if it’s your only browser. https://help.vivaldi.com/desktop/install-update/full-reset-of-vivaldi/

Edit: Saw your last post about the private window. Def a cache issue in Vivaldi.

I just did a full cache/cookie wipe and it worked. Didnt want to go that route but had to be done I guess. Anyways all good now :slight_smile:

Glad you got it working.

Chrome does that from time to time. I swear it’s an addon that causes it. By itself with all extensions disabled I can run 500+ pages with no issue. Yea I hate using favorites lol.