Database failure

Trying to get a backup (local) running and I get a ‘database was attempted repaired’ message. If I purge the DB it immediately fails, if I try to repair it it reports no files in database. I’ve deleted the backup and recreated it, but that doesn’t fix it either. I’ve also uninstalled Duplicate and reinstalled it. I’ve got the VS distro packages installed, I verified that.
Basically I’m stuck. Is there any trick to really forcing this to start again? A special command line tool or setting?

Welcome to the forum!

Can you elaborate? If you can copy/paste the exact message that may be best.

If the local database gets damaged, it can be regenerated from your backup data. Does the backup data still exist or was it also deleted? Worst case scenario is to start completely over, but that should not be necessary.

Also let us know what version of Duplicati you are using, on what platform (Windows, Linux, etc), and what back end you are saving to.

Sorry, wow did I really blow that message.

Windows Server - Duplicati 2.0.5.1

If I try to run a backup, I get:
The database was attempted repaired, but the repair did not complete. This database may be incomplete and the backup process cannot continue. You may delete the local database and attempt to repair it again.

If I go to the database option and click Recreate I get:
No filelists found on the remote destination.

I have deleted the backup and recreated it, and get the same error sequence. Note that the offsite portion of the same backup seems to work fine, so it seems the application is working well, it just seems specific to this backup.

Is the destination for this backup truly empty?

Right now, there are 43 Duplicati AES files in the folder it is backing up to. I tried moving them out of the folder and rebuilding, but get the same set of errors.

If you want to try keeping the existing backup data, move the AES files back and we need to troubleshoot why Duplicati doesn’t see them. What back end (protocol) are you using for this backup?

For backend I’m really not sure - this is to a local drive, if that is helpful.

refers to a specific type of file. If you sort files alphabetically, three types will become clearer. The one looked for here will have backup’s date and dlist in its name. The others should have -b*dblock or -i*dindex. Ordinarily an odd number of files is expected, as there’s a dindex per dblock, then a dlist listing all the files. So I’m not quite sure what you have, but I suspect you don’t have a dlist. It’s sent after files have been backed up. Has a backup ever completed? If not, that explains No filelists

Whenever I want to empty out a job (while not actually deleting it), I use the Database Delete button, along with manually deleting the remote files. But was it figured out what went wrong on past backup?

About --> Show log --> Live --> Warning could show live log for a better view of where things fell apart.

Oddly enough, I fixed it after a fashion. I left the backup in place and created a completely new one, and ran that successfully. I then deleted the old one. I’m guessing it failed on it’s first run-through and never recovered from that, but I couldn’t find anything in it’s logs to show me what happened.
All’s well that ends well.