Data migration from the USA to Europe at pCloud : "The remote server returned an error: (401) Unauthorized"

I have a problem to backup to pCloud. Indeed, a few days ago I asked pCloud to migrate my data from their servers in the USA to their European servers (in Luxembourg). Since this migration I have good access to my data through my browser but my backups using webDAV send me the following message: "The remote server returned an error: (401) Unauthorized.”
My version is
My settinggs :
Port: 443

Here is an excerpt from the log :

20 févr. 2021 21:22: Failed while executing “Backup” with id: 47
System.Net.WebException: The remote server returned an error: (401) Unauthorized.
at System.Net.HttpWebRequest.GetResponseFromData (System.Net.WebResponseStream stream, System.Threading.CancellationToken cancellationToken) [0x0017e] in :0
at System.Net.HttpWebRequest.RunWithTimeoutWorker[T] (System.Threading.Tasks.Task1[TResult] workerTask, System.Int32 timeout, System.Action abort, System.Func1[TResult] aborted, System.Threading.CancellationTokenSource cts) [0x00118] in :0
at Duplicati.Library.Main.BackendManager.List () [0x00049] in <60a7e79acb3b49e8af8a73149919d15b>:0
at Duplicati.Library.Main.Operation.FilelistProcessor.RemoteListAnalysis (Duplicati.Library.Main.BackendManager backend, Duplicati.Library.Main.Options options, Duplicati.Library.Main.Database.LocalDatabase database, Duplicati.Library.Main.IBackendWriter log, System.Collections.Generic.IEnumerable1[T] protectedFiles) [0x0000d] in <60a7e79acb3b49e8af8a73149919d15b>:0 at Duplicati.Library.Main.Operation.FilelistProcessor.VerifyRemoteList (Duplicati.Library.Main.BackendManager backend, Duplicati.Library.Main.Options options, Duplicati.Library.Main.Database.LocalDatabase database, Duplicati.Library.Main.IBackendWriter log, System.Collections.Generic.IEnumerable1[T] protectedFiles) [0x00000] in <60a7e79acb3b49e8af8a73149919d15b>:0
at Duplicati.Library.Main.Operation.BackupHandler.PreBackupVerify (Duplicati.Library.Main.BackendManager backend, System.String protectedfile) [0x0011d] in <60a7e79acb3b49e8af8a73149919d15b>:0
at Duplicati.Library.Main.Operation.BackupHandler.RunAsync (System.String sources, Duplicati.Library.Utility.IFilter filter, System.Threading.CancellationToken token) [0x01048] in <60a7e79acb3b49e8af8a73149919d15b>:0
at CoCoL.ChannelExtensions.WaitForTaskOrThrow (System.Threading.Tasks.Task task) [0x00050] in <9a758ff4db6c48d6b3d4d0e5c2adf6d1>:0
at Duplicati.Library.Main.Operation.BackupHandler.Run (System.String sources, Duplicati.Library.Utility.IFilter filter, System.Threading.CancellationToken token) [0x00009] in <60a7e79acb3b49e8af8a73149919d15b>:0
at Duplicati.Library.Main.Controller+<>c__DisplayClass14_0.b__0 (Duplicati.Library.Main.BackupResults result) [0x0004b] in <60a7e79acb3b49e8af8a73149919d15b>:0
at Duplicati.Library.Main.Controller.RunAction[T] (T result, System.String& paths, Duplicati.Library.Utility.IFilter& filter, System.Action`1[T] method) [0x0026f] in <60a7e79acb3b49e8af8a73149919d15b>:0
at Duplicati.Library.Main.Controller.Backup (System.String inputsources, Duplicati.Library.Utility.IFilter filter) [0x00074] in <60a7e79acb3b49e8af8a73149919d15b>:0
at Duplicati.Server.Runner.Run (Duplicati.Server.Runner+IRunnerData data, System.Boolean fromQueue) [0x00349] in <97751f2e2d7047e983f74950165267e2>:0

Is it a question of authorization (“CancellationToken”) that would have changed and that Duplicati did not take into account ?

I have contacted pcloud but I have no answer for the moment.

Thank you for your help and long life to Duplicati.
Yours sincerely


I have the same issue since tonight : I just ask to migrate my data from USA to Europe.
And now, all backups are failing with error 401.

I will try change the password of account through the web site, and see if it unlocks the situation.


Nope, setting the new password didn’t make the trick… :frowning:

Does pCloud document their WebDAV? I see some third-party sites saying is the European version of so maybe you can try that or their support will get back to you.

Hello again,

This is strange, I couldn’t find any information on webdav access anymore on the web site…
But I found a way cleaner way to use duplicaty and pCloud : Rclone !

Further more, as I wanted to use double authentification, I wouldn’t be able to use webdav anymore anyway…
So now, everything is clean, and working properly.
I installed rclone in the duplicaty docker container, and voilà :slight_smile:
Tonight, the backups will run, and I will see tomorrow.

By the way, the only documentation I found is here :

Thank you for your feedback ts678. I will try to connect with this URL with winscp to see if it works.
Maybe pointnemo will give it a try before me ?


J’ai reçu la réponse suivante du support de pCloud. je n’ai rien encore testé.
"Je suis vraiment navré, de notre côté on ne peut pas vous apporter de support pour un logiciel tiers. Je sais pas de quelle manière il se connecte à notre serveur. Concernant le token, je en vois un, qui a été créé le 19 février pour votre Linux Mint. Donc très probablement il suffira de redémarrer l’ordinateur. Si ça ne se fait pas je vous conseille de :
1 - Supprimer /home//.pcloud
2 - Supprimer /home//.config/autostart/pcloud
Veuillez noter qu’en supprimant la base de données, vos paramètres de synchronisation seront réinitialisés. Aucun fichier ne sera cependant perdu. Vous pouvez les reconfigurer après avoir lancé l’application. Maintenant, démarrez/ouvrez à nouveau pCloud Drive sur votre ordinateur. "

À suivre…

I received the following answer from pCloud support. I have not tested anything yet.
"I’m really sorry, on our side we can’t give you support for third party software. I don’t know how it connects to our server. Concerning the token, I see one, which was created on February 19th for your Linux Mint. So most probably it will be enough to reboot the computer. If it’s not done, I advise you to :
1 - Delete /home//.pcloud
2 - Delete /home//.config/autostart/pcloud
Please note that by deleting the database, your synchronization settings will be reset. However, no files will be lost. You can reconfigure them after launching the application. Now start/open pCloud Drive on your computer again. "

To be continued…

Always the same answer from pCloud team… “you are using webdav, so it is your fault…” :face_with_symbols_over_mouth:
And as rclone is officially supported, they can’t say they can’t help you :upside_down_face:

Do not hesitate : use rclone in front of duplicati !
you’ve got all the documentation needed on the duplicati’s web site and on Well documented for both.

tips : for rclone, do not forget to create the “local” remote :wink:


I confirm that replacing the server name by seems to solve the problem.
Indeed, I followed the following procedure:

  1. Stopping the pcloud application (pCloud Drive under Linux)
  2. Removing of home/.pcloud and home/.config/autostart/pcloud.desktop (as indicated by the pCloud support and to start again on a good basis…)
  3. Restarting the pcloud application that needs to be reconfigured (especially the local folders to synchronize; it then seems to recheck in upload and download all the synchronized files…)
  4. Modification of the server name in my Duplicati backups by (many thanks to ts678 :+1: see or
  5. Regeneration (“delete and repair”) of the local database of each backup (just to start again on a good basis…)
  6. Manual launching of backups

What’s incredible is that pCloud’s support did not suggest changing the name of the server following the migration from a US server to a European server…I have reported to pCloud support the necessary change of server name depending on data region … :roll_eyes:

Best regards

1 Like
works for me in Europe

but are you on a European server, or just reaching out over the Internet? Some care about storage site.

Although it’s not a positive guarantee of the underlying storage site, you can look up host or IP location. and such find in U.S, ewebdav in Luxembourg. hints at the naming convention, e.g. is api located in Europe.

Correct, I was mistaken.
Looking at the web interface the server location is US.

Hello all,

For what it’s worth : since I use Rclone to connect to pCloud, I don’t have connections and transfers errors anymore… maybe it is linked to have migrated to european data centers also.

And I have now transfers rate up to 10 MB/s. Before I was roughly at 2MB/s…
And I’ve got a fiber upload speed of 300Mb/s :slight_smile: so there is room for improvement.

But the main win here is that I don’t have thousands of “unknown” connections in the Security settings… :slight_smile:

Use Rclone, it is simple !