Crash after update to " ("

After updating from the 2019 version to the latest one (on Win8.1, German) Duplicati doesn’t start any more.
In detail: I installed the update from the GUI and then clicked on “activate”. This was followed by “connection to server lost, try again in … seconds”. Since there was no way to get rid of this pop up after several futile attempts to reconnect (to which server?), I closed the brower tab.

When trying to start again through my ususal shortcut (“C:\Program Files\Duplicati 2\Duplicati.GUI.TrayIcon.exe”) nothing happened.

Then I ran the same command from a command prompt and got a huge number of errors, but my prompt only returned after killing execution with CTRL+C. Redireting the messages into a file failed, so I copied them manually (hence the odd line wrap).
Some excerpts of the messages:
“Unexpected error: System.IO.FileLoadException: Die Datei oder Assembly “Newtonsoft.Json, Version=, Culture=neutral, PublicKeyToken=30ad4fe6b2a6aeed” oder eine Abhängigkeit davon wurde nicht gefunden.” [i.e.Json file or dependencies were not found]
System.Reflection.TargetInvocationException: Ein Aufrufziel hat einen Ausnahmefehler verursacht.” [i.e. target call caused an exception]
… followed by a call stack.

For more details see log attached (I can translate more text if required) (1.5 KB) .

Any ideas what’s wrong here? Is there a way to revert to the previous version?
BTW I successfully updated my installation on a Win10 Laptop in the same way (but I don’t recall clicking “activate” to get it working OK)

1 Like

Sounds similar to this thread.

Instead of start of “C:\Program Files\Duplicati 2\Duplicati.GUI.TrayIcon.exe”, could you try starting the Duplicati.GUI.TrayIcon.exe directly? Also, what version does Program Files changelog.txt say?
Update design puts the updates in a different location which doesn’t require Administator permissions.

Downgrading / reverting to a lower version shows several places to inventory for installed updates, e.g.
C:\Users\<Duplicati user account>\AppData\Local\Duplicati\updates
and I say that not to encourage downgrade, but to debug this upgrade issue by looking at old versions.
There may be something on some systems that does it. Both you and I have seen starting fine.

The link from @drwtsn32 includes some explanations from me on the unusual way that updates work. Although I’m not a .dll expert (I hope someone else is), I think Newtonsoft.Json just went from 10 to 12, however the old Program Files one should have used 10, and the update should have found 12.

Your start of directly will probably go 12 initially for parent and child (both on, and if that works, then uninstall and reinstall from .msi will put Program Files on and maybe all will be well, however if you can help with figuring out where this is going wrong, narrowing it down would be helpful.

Thank you @drwtsn32 and @ts678 for your prompt suggestions!

Here is what I did, step by step:

  1. Checked my installations, took zip-snapshots of each folder:
    C:\ProgramData\Duplicati\updates (46MB),
    C:\Program Files\Duplicati 2 (14MB)
    C:\users<acct>\AppData\Local\Duplicati (400 MB)


a) C:\Program Files\Duplicati 2\changelog.txt oddly enough has “2017-08-01 -” as latest version on top (all files in this folder have a change date time stamp of Aug 1st, 2017, probably my last update installation date).
b) C:\ProgramData\Duplicati\updates
- contains versions, and; “current” indicating is the active one.
- \2.0.4.*\Newtonsoft.Json.dll is of version (not signed)
- \\Newtonsoft.Json.dll is of version (digitally signed)

  1. Started C:\Program Files\Duplicati 2\Duplicati.GUI.TrayIcon.exe directly (on cmd prompt) and got the very same crash message as before (about wrong DLL version).

  2. Uninstalled “Duplicati” (sic!) from control panel (installed version indicated: from Nov 2017)

  3. Downloaded and installed duplicati- with default options

a) According to control panel now I have “Duplicati 2” installed with version
b) C:\Program Files\Duplicati 2\changelog.txt now has “2020-01-18 -” on top

  1. After starting Duplicati it immediately popped up a notification that “an update is available”, despite displaying the very same update being installed already - dismissed.
    When I launched the first backup job I got a prompt “do you want to start the server” (or was it service?). After OK, the job started and finished OK.

So a clean install seems to have done the trick for me.

I’m afraid I can’t contribute much to root-causing this problem. If it is of any help, I can provide access to (parts of) the snapshots copies I made of the installation folders before my reinstall (see above). was probably the last (and maybe only) .msi install. Updates done by Duplicati go elsewhere, and thank you for surveying them. At least one of the other people with this issue went way back too.

was not the test below. The key difference was not a CLI start, but which .exe got started. The order shown says that perhaps below was just repeating the original test from, running:

C:\Windows\System32>"C:\Program Files\Duplicati 2\Duplicati.GUI.TrayIcon.exe"

so it’s no surprise that it gave the same error. The intent was to start the version, not the old. After the uninstall and reinstall from .msi, the chance is gone, but the good news is so is the error…

Knowing now where things went (and to help any other person who reads this), the intent was to try:


so that an older Program Files version (which might want version 10) would not start. Checking Task Manager for leftover old Duplicati processes would also be good, and I forgot to mention that as well.

Wonderful to hear. You also did the uninstall first, which used to be needed to avoid missing file issues. That’s supposed to be fixed now, but it seemed safer to not add any worry, with so much else going on.

I’m glad it’s back, and thanks for adding some more bits of information, as we try to figure out the issue.

…the intent was to try:

Ah - I see. Sorry I missed your point and thanks for repeating the full path for others to understand right away :slight_smile:

You also did the uninstall first,

Yep, I didn’t want to take chances being left with a garbled installation

I’m glad it’s back,

So am I - and and I’m looking forward to many more silent backups and unspectacular restores whenever necessary :slight_smile:
Thank you to you and everybody else in this very active user forum.
You guys are a role model for responsiveness!