Connection to the server is lost on OpenMediaVault 4

Duplicati installed via Openmediavault 4. After initial install, Can access web interface, and have set up backups and is nicely backing up to amazon drive. However when I reset the machine and then try to access the duplicati web interface i first get a popup that says that the XSRF toekn is missing, which is then quickly replaced by the message "the connection to the server is lost, attempting again in … ". This loops indefinitely and is not fixed by a reboot. I have tried renaming this file: duplicati/webroot/package/ngax/package.js, as suggested here

any suggestions to get around this? I have tried a complete reinstall of OMV and duplicati, but the problem recurs, and I am currently locked out of controlling duplicati
Many thanks

There are a few caching issues in all but the most recent canary build. Clearing the browser cache (or pressing CTRL+SHIFT+F5) should allow you to load the page.

Thank you kenkendk for replying.
Not sure whether this will be of help to you or anyone else, but this is my experience of this issue:

  1. Using safari and firefox - still get this message.
  2. Clearing the browser caches (safari and firefox) and refreshing page - still get this message.
  3. Different computer - can access for a while and then this message appears on new computer when i trying to re-access duplicati.
  4. Accessed duplicati web interface via a firefox in a linux virtual machine - still get this message.
  5. uninstalled the standard duplicati plugin on the OMV4 NAS, and then installed duplicati via a docker image on the same OMV4 NAS, and then accessed using several different machines as per 1-3 above - gave the same message.

The one thing that seems to work is to use chrome. occasionally get the XSRF token is missing dialogue, but so far this can be dismissed by refreshing the browser window.

Welcome to the forum @granit, and thanks for using Duplicati!

Can you tell whether or not backups are continuing to run even if you can’t get the web UI to play nice?

Also, what version of Duplicati are you running? I know there have been some improvements in the XSRF issue since the beta that packages & Docker containers seem to like to use.

Lastly, there are a few other OMV related posts on the forum. I don’t recall any specifically about the issue you’re seeing, but if you haven’t checked them out yet they might be worth a quick read to see if they give you any ideas.

(Oh, and I updated the topic title to include that this is on OpenMediaVault to make searching a little easier. Please let me know if you disagree with that.)

Hi JonMikeIV,
Yes, the backups are still running in the background even if the web UI is not function properly.

I a currently running but this issue was also present when running

So long as I use chrome I can overcome this problem.

Thanks for updating the topic.

Good - that means the issue is most likely “just” a GUI communications problem and not something wrong with the server itself.

That’s odd, but it does support the GUI communication issue theory. Is it possible the failing browser has a plugin that might be interfering? I had an AV issue on one of my machines that broke the web GUI for my unRAID box…I ended up switching AV tools.

I suppose it’s also possible the failing browser has some “odd” settings like using a proxy server or routing stuff through the TOR network…