Confusing SFTP ssh fingerprint warning

Whenever I run a SFTP backup I’m getting the following “[Warning-Duplicati.Library.Main.Controller-UnsupportedOption]: The supplied option --add --ssh-fingerprint is not supported and will be ignored”

However if I remove the offending option then the backup won’t run and I get the following “Please add --ssh-fingerprint=“REDACTED” to trust this host. Optionally you can use --ssh-accept-any-fingerprints (NOT SECURE) for testing!”

So it seems that the option is not supported but the backup won’t run without it?!

This is not a deal breaker but its rather annoying to get the warning every time.

Looks like you have --add in there? Try removing just that part.

BTW if this is a GUI backup configuration, it’s easiest to use Destination screen Test connection to set --ssh-fingerprint. The style shown on backup is generic and may need adapting depending on how it’s used. For example, three-dot menu on Destination Advanced options doesn’t use quotes, but shell does.

The --add option is the only choice for the GUI so I edited in commandline and removing it does seem to fix the issue. However I can also just delete the whole --ssh-fingerprint option in commandline and it runs without any errors, which doesn’t seem quite right!

What screen and where on it? Can you paste a screenshot? I have not heard of an --add option.

If you mean GUI Commandline screen, note that this won’t edit the saved job. It’s one Command.

Options related to the destination are often on the Target URL Look in that box for something like:


I should clarify: if including the --ssh-fingerprint option using the GUI, it translates to --add --ssh-fingerprint in the GUI Commandline screen. So when I say its the only choice I mean there is no way to add just --ssh-fingerprint using the GUI.

Below is how it looks in the GUI Commandline. As stated before if I remove just the --add and then run the backup then it runs without any ssh error message, however it also runs fine if I delete the whole --add --ssh-fingerprint option. But if running from the normal GUI the backup wont run without the --add --ssh-fingerprint option.

Where in the GUI, and how? If I use Commandline Advanced options, to add from menu, set as I showed, then Edit as text for a closer look (I’m not sure why one would usually do this), it’s fine and it can run test.

If I use previously mentioned Destination Test connection to add it, then save the change into the job, then Commandline to look at it, then Edit as text for a closer look, it’s not in the Advanced options section but in Target URL section unlike the above paragraph where it was put into Advanced options but not Target URL.

If on the Destination screen I don’t use Test connection button, but use Advanced options to set the option, then do the same Save + Commandline look as previous paragraph, I get same result. A backup runs fine.

If you’re doing this all in Commandline, why? That’s only good for the one operation shown on that screen.

Possibly there’s some browser-based difference to explain difference. I’m testing this with Microsoft Edge.
I don’t have all browsers, but please say what you’re using to get your results, and say step-by-step setup.

Above are three ways, but for permanent addition, do it on the Destination screen, and for ease, using its Test connection button is easier than trying to transcribe then edit a backup popup to do a manual add.


Fourth way that works (and can Save) is Advanced options on Options screen rather than on Destination.

I still haven’t seen an --add. As for deleting the --ssh-fingerprint option then seeing it still work, image posted showed it in both Target URL and Advanced options (unlike my tests). Maybe you must delete both.

I’ve added it two different ways in the GUI, both by using the Test connection button and using the ssh-fingerprint option under Destination>Advanced options.

Using either method I get the same warning message (i.e. option not supported and will be ignored) and when I check the GUI Commandline text option it looks like my earlier screengrab (the --add --ssh-fingerprint is in the Advanced options). I have also tried in Edge and get the same result.

I am not doing anything in GUI Commandline. I am just using it to troubleshoot.

Well, I guess we can see if anyone else who’s reading and willing can reproduce either your or my results.
I don’t recall such reports, but I don’t think I mounted much of a search of the forum and Duplicati’s Issues


I’m trying Google search.

"add ssh-fingerprint" and searching snippets for --add finds only this report.
Issues found even less. I suppose some other potential risks for things sneaking in are in Default options from the Settings screen, or possibly even browser saved data doing autofill. The latter seems less likely because this doesn’t look like the password field I’m used to, where the browser asterisks to hide a value.