Configuring Duplicati 2 for Memstore (Memset Ltd)

As a home user who is not an IT expert, I was getting on happily with Duplicati 1.3.4 but a change in Windows 10 means that won’t work any longer and I have no guidance on how to set up the newer version of Duplicati, which has an interface that looks very different and does not seem to have the same required inputs to make it work. Can anyone advise me, please?

The (prerelease of the) manual is a good start:

This looks as if it is composed for people who are already familiar with the topic, not utter novices like me, but thank you for the suggestion.

Welcome to the forum!

Sorry to hear the (prerelease) manual isn’t quite what you need. So let’s start by figuring out where you’re at. Am I correct in assuming you have Duplicati 2 installed already, can get to the web GUI, and are just trying to setup Memstore as a backup Destination?

Yes, you are quite right about the situation, but I am very pleased to report that tech support at the storage provider has this morning helped me through what to enter on the GUI. It passed the “test connection” hurdle. This afternoon I will find out whether Duplicati 2 springs into action at the time I set.
Its icon is not showing as an active program in the way the older version’s icon did, which is a bit worrying, but maybe it doesn’t work that way now.

I’m not familiar with how version 1 worked, but I expect the schedule will work as, um, expected.

Glad to hear the Memstore provider was able to help you out! If you have time, please feel free to post (or link to) what worked for you in case other users of that cloud provider / destination are out there. :slight_smile:

I will post up the successful settings when I am sure Backup is working. Currently, my first full backup run started but threw up 1143 errors, and since then it complains that the database is locked and will do nothing useful.

Can you provide details on any of these?

  • What version of Duplicati are you using?
  • Are you running the tray icon, service, or both?
  • Can you copy/paste the exact error about the database being locked?

I have
I tried opening it now and got an error message “Missing XSRF Token” which means nothing to me.
Yesterday when running backup it gave this: image
I do not understand the question about ‘tray icon or service’. I do have an icon for Duplicati 2 that appears in my “Hidden icons” box (Windows 10, bottom right up-arrow symbol). When I click that, it opens a window in the default browser (Firefox).

Memset (who provide my cloud storage space) says “In this case that looks to be having trouble connecting to the databases that you have stored on your machine, I would most certainly go to the duplicati forums to see if anyone else has had something similar happen.”

Very grateful for any help that allows me to get a successful back-up run.

In an attempt to replicate the missing token error, it gave me not that (which appeared in a blue box) but the following in a red box at the foot of the screen "Unexpected number of remote volumes detected: 0!"
I had no difficulties as all with the earlier version of Duplicati, which ran well for quite a long time, but stopped when something in Windows changed, at which point Memstore told me to update to the newer version, since when I have had no luck at all with it.

The missing token error is a known issue. It just means the web GUI couldn’t connect to the service or Tray Icon. It usually goes away if you refresh (F5) your browser tab.

The 0 remote files error means Duplicati’s local database has recorded that backup files have been uploaded previously but now it’s not finding them.
This is usually caused by either connecting to the wrong destination folder OR somehow the destination files got deleted.

I can’t speak to your experience of version 1 vs. version 2 stability, sorry.

Thank you. The browser refresh is something I can try if at the computer at a suitable moment. I have passed the issue of not finding the files to the storage provider. Mind you, since switching to Duplicati 2, I have not had a successfully completed backup session, so there may be no files there (I do not think it is able to connect to all the data I uploaded as backup there using the older version of Duplicati, sadly). Might it be recognising that an upload session started and went on for a long time, and so expect to find that data, but, because that did not finish cleanly, be unable to find it?

As far as I can tell, the backup worked correctly this evening, and there are lots of files held in the store that went on the days before the latest error showed up, so it may be that all is now well. I will pop back here if I get any other error messages, and meanwhile I will generate the guidelines for anyone else who wants to set up Duplicati for Memstore.Thank you for your support.

1 Like

When configuring a new backup in Duplicati 2 for use with Memset/Memstore Cloud storage, this is what appears to be working for me.

General backup settings screen: Use the setting AES-256 encryption built in.

Backup destination screen:
Use storage type OpenStack Object Storage /Swift
Under that I was told to use my initials in the ‘Bucket name’ box, then under that the Custom server URL, then ‘username’ admin, then in the two boxes below that my Memstore password and ID.

Hope this is helpful.


Awesome, thanks for sharing that!

It sounds like your backup is progressing so I flagged your post as the solution. If that’s incorrect, please let me know.

I will monitor the situation and report back if I notice any further problems. As for now, the “solution” is the best I can offer until it is proven.