Configuration seems to have disappeared after reboot?

Hi -

I’m on Arch Linux, Duplicati This gets installed from the Arch User Repository (AUR) and has worked fine for years.

Today I did a system update (yay -Syu) and after reboot my Duplicati configuration is gone. No jobs, nothing.

Configuration is supposed to be in ~/.config/Duplicati (apparently) but that folder doesn’t exist. It doesn’t exist for root, either.

Systemd service is running, have restarted it, have rebooted.

I can setup the jobs again but I don’t want to do that. I’ll lose my database and backup history (I can never get the database restored from the on-disk backup files, which I do still have access to).

What happened/what else can I check?

I am using Manjaro, using the same version as you. In my case, the following solved the problem.

  1. The configuration was supposed to be in /root/.config/Duplicati/. However, the systemd file (which was damaged, it had the wrong user) pointed to a EnvironmentFile in /etc/default/duplicati. In there was the definition DUPLICATI_HOME=/var/lib/duplicati.
  2. Following the path found that the structure was similar to /root/.config/Duplicati/ but some files were missing, specifically a database.
  3. I copied all the files from /root/.config/Duplicati/ to /var/lib/duplicati/ (after making a backup of course).
  4. After I fixed the service file, I reloaded the systemd unit and restarted the service. I used systemctl daemon-reload
    systemctl reastart duplicati

The backup jobs reappeared and they started, as they should.
Hope this helps you too. Please let me know what happened or if you find a different solution

1 Like

It would be worth a look at ~duplicati/.config/Duplicati to see what it has (ideally your config, etc.).
The historical issue with Arch is that AUR liked to run as a duplicati user (secure but complex).

Welcome to the forum @NBoumakis and thanks for the help. There might be related info at AUR:

Package Details: duplicati-latest

Previously I only knew of old issue, but the recent change with typo reminds me of things you said.