Clear local logs

Hi there

I’ve got a few errors in my logs from early configuration. These are showing in the UI whenever I start it, so I keep having to dismiss them even though the last few days of backups have worked fine.

How do I clear the logs, please?


Welcome to the forum @sonic

You use the Dismiss button, right? Did it clear? If so, did any notifications come back before restart?
I think restart just shows you whatever notifications were already sitting on the screen, undismissed.

I assume you’re talking about the notifications that pop up near screen bottom, with dismiss buttons.
You can’t selectively delete job logs from Show log for the particular backup, but they’re hard to see.

Thanks for your help!

Yes, I used the dismiss button but the next time a scheduled job ran, the previous errors seem to be re-alerted.

I’ve tested it a few times though and did not get the same result so I’ll leave it for a bit and pay more attention the next time I see them!


How do you know it’s not the same error happening again?

If you’re talking about the red popup, they’re all very similar.

Try checking About → Show log → Stored or watch About → Show log → Live → Error

Would be a log clearing issue, if “start it” means start Duplicati, but

is a backup. Maybe “it” in first one was. I can’t tell.

Note that if you have scheduled jobs that miss their schedule, they will run soon after Duplicati starts.
This makes it more confusing about whether it’s a Duplicati start or a backup start giving that error…

My descriptions were ambiguous, you’re right! Thanks for your help.

The backups ran fine overnight and there are no errors showing this morning so seems all OK now, but to answer your questions:

I knew it was the old errors because the home page showed them all as completed OK, so after seeing and dismissing the errors I looked in the log and saw that the only errors listed were from days ago. All subsequent backups reported success.

When I said ‘start the UI’ I meant open a browser pointed to the Duplicati URL. In this case it was from the system tray icon but the same thing happened on a remote browser.

Anyway, seems fine now so perhaps I had not dismissed the old errors correctly, so I was being shown them again which would be expected.


1 Like

Some more on this after a few tests.

Duplicati still shows old warnings every time my backups run. When I click Show, all I can view are successes - I can keep clicking ‘Load older data’ until no more will be shown, and again there are no errors on any page for any of the errors.

If I click Dismiss on each error, or I click Dismiss all, the messages always come back after the next overnight run.


There is only one error in About > Show Log > Stored.

How do I find, and dismiss them?


Try watching About → Show log → Live → Warning while a backup runs. Try clicking on any that you see.

Thanks, good tip.

I can see what the errors are now, and what the cause is.

UsageReporter failed (due to a 404).

This is because I want Duplicati to perform a webhook call after backups complete, so that I can (ultimately) monitor them in OpenHAB. I was testing with a address, and forgot to remove it after the tests.

The result in the log is below - it’s the 404 HTML that’s being returned by

What’s strange is that the log for the backup at the same time reports no warnings, which is why I couldn’t find them until you directed me to the live log.

I do still get the popup notifications that I started the thread with.

So, it looks like there’s no problem as such, but it would be really good if the warnings that show in the notifications also show in Backup Name > expand > Reporting > Show Log… - because they do not at the moment.


I think the backup logs reflect the results of the backup itself. Such results can be reported in a variety of ways, such as email or http, however an error in post-backup processing doesn’t update the backup log reporting the results of the backup itself. This is maybe also why a backup that doesn’t finish lacks a log reporting the result statistics (look at a Complete log – I think it’s done when it’s done) and later events.

This log is from the local database and is a preformatted text string, so it’s hard to update once it’s made:

That makes sense, there was nothing wrong with the backup itself.

Perhaps the exception produced by UsageReporter in this instance could be caught and directed to some system log, so it doesn’t produce a warning notification to the user for the backup itself - since the backup worked OK.

Or maybe all UsageReporter exceptions could go somewhere else?

Because this is getting technical, UsageReporter is documented here and coded here to make web site: (seems down now because server is down)

send-http-url is probably what you’re talking about, and the code that does the HTTP request might be at

and seems like it could potentially log in several ways. The live log (or file log) format differs from the one posted by you as an image. That one looks more like the server log. The multiple-log situation has issue:

Combine logs in GUI #1152 is possibly hard to fix, or the original author would have fixed rather than filed.

For technical reasons there are multiple logs.

This is really confusing to the user as they do not understand why and what happens underneath.
the below, although the error message posted

There might be other open issues on logging that would cover your case. If not, you can file one with the exact steps necessary, and what you suggest (maybe above helps). The forum cannot track any issues.

Developers are in short supply (as are volunteers in all areas), so feel free to submit a PR if you do code.