Changing configuration of a backup with @ in the path


#1

Hi,

For one of my backups I cannot change the settings properly via the UI (*)
I suspect this is due to the presence of an “@” in the “Path on server”
In the json (when using export config): it shows correctly as:
TargetURL": “ssh://10.0.72.90:22//homes/@LP-BU.CITY.EXAMPLE.COM/0/username-1050/duplicati2-backup?auth-username=username&auth-password=XXX&ssh-fingerprint=ssh-rsaxxxxxx”
But in the UI it shows as:
Storage Type: SFTP (SSH)
Server and port: LP-BU.CITY.EXAMPLE.COM <Port empty!>
Path on server: 0/username-1050/duplicati2-backup
Username: username
Password: ***********

Since the (wrong) split happens at the @, I suspect the error is somewhere in an algorithm trying to extract username:password@server:port/folder pattern, which doesn’t apply here.

PS: (*) workaround is to restore the values of these “Server”, “Port” and “Path on server” fields every time you edit any parameter in the backup, but this is a nuisance, and if you forget the parameters or forget to restore it, you screw up your backup job.
PS2: who on earth starts a foldername with an @? Well, Synology NASes do if you use LDAP auth.
version Duplicati - 2.0.4.5_beta_2018-11-28