Can't Use Any Backends with AuthId

I’m running the latest beta Duplicati on Linux Mint 18.
I have several backup sets working fine that point to backends that don’t require an AuthId (i.e. mega, webdav, B2)

I tried to configure 2 separate backup sets to different backends that require an AuthId as the authorization.
Both of them failed with the following error after several seconds/minutes of waiting while testing the connection:

Failed to connect: Failed to authorize using the OAuth service: GetResponse timed out. If the problem persists, try generating a new authid token from:

That one was for box; a similar error happened for Hubic.
I tried generating several new authid tokens and that didn’t help.

I’d like to use these backends, but I’m stuck trying to authorize to the backends. Any ideas?

I set up a AuthID for testing at some point within the last 2 days, when did yours fail?

Is it possible you’re running into the issue resolved by adding the --accept-any-ssl-certificate=true parameter?

Mine has failed today and the past 2-3 days straight.
When I add the accept any ssl cert option, that’s when I get the error previously indicated.

When I don’t use the accept any ssl cert option, I get the same error.

Here is what is in the logs:

Duplicati.Library.Interface.UserInformationException: Failed to authorize using the OAuth service: GetResponse timed out. If the problem persists, try generating a new authid token from: ---> System.Net.WebException: GetResponse timed out ---> System.Net.WebException: Aborted.
  at System.Net.HttpWebRequest.EndGetResponse (IAsyncResult asyncResult) <0x411f9a50 + 0x001a3> in <filename unknown>:0 
  at Duplicati.Library.Utility.AsyncHttpRequest+AsyncWrapper.OnAsync (IAsyncResult r) <0x411efd00 + 0x000eb> in <filename unknown>:0 
  --- End of inner exception stack trace ---
  at Duplicati.Library.Utility.AsyncHttpRequest+AsyncWrapper.GetResponseOrStream () <0x40646ec0 + 0x0010b> in <filename unknown>:0 
  at Duplicati.Library.Utility.AsyncHttpRequest.GetResponse () <0x411f2e70 + 0x00163> in <filename unknown>:0 
  at Duplicati.Library.JSONWebHelper.GetResponse (Duplicati.Library.Utility.AsyncHttpRequest req, System.Object requestdata) <0x413aab80 + 0x0040f> in <filename unknown>:0 
  --- End of inner exception stack trace ---
  at Duplicati.Library.OAuthHelper.get_AccessToken () <0x413aa000 + 0x007a7> in <filename unknown>:0 
  at Duplicati.Library.OAuthHelper.CreateRequest (System.String url, System.String method) <0x413a9db0 + 0x0006f> in <filename unknown>:0 
  at Duplicati.Library.JSONWebHelper.GetJSONData[T] (System.String url, System.Action`1 setup, System.Action`1 setupreq) <0x413a9cc0 + 0x00038> in <filename unknown>:0 
  at Duplicati.Library.Backend.Box.BoxBackend+<PagedFileListResponse>d__17.MoveNext () <0x413a97e0 + 0x00217> in <filename unknown>:0 
  at System.Linq.Enumerable+WhereEnumerableIterator`1[TSource].MoveNext () <0x4060dc20 + 0x00162> in <filename unknown>:0 
  at System.Linq.Enumerable.FirstOrDefault[TSource] (IEnumerable`1 source) <0x404e8730 + 0x000be> in <filename unknown>:0 
  at Duplicati.Library.Backend.Box.BoxBackend.GetCurrentFolder (Boolean create) <0x413a9000 + 0x001ef> in <filename unknown>:0 
  at Duplicati.Library.Backend.Box.BoxBackend.get_CurrentFolder () <0x41388f00 + 0x0001f> in <filename unknown>:0 
  at Duplicati.Library.Backend.Box.BoxBackend.List () <0x41358e30 + 0x00017> in <filename unknown>:0 
  at Duplicati.Library.Backend.Box.BoxBackend.Test () <0x41388e30 + 0x0000f> in <filename unknown>:0 
  at Duplicati.Server.WebServer.RESTMethods.RemoteOperation.TestConnection (System.String url, Duplicati.Server.WebServer.RESTMethods.RequestInfo info) <0x41392140 + 0x003e0> in <filename unknown>:0 
  at Duplicati.Server.WebServer.RESTMethods.RemoteOperation.POST (System.String key, Duplicati.Server.WebServer.RESTMethods.RequestInfo info) <0x41391d80 + 0x001e7> in <filename unknown>:0 
  at Duplicati.Server.WebServer.RESTHandler.DoProcess (Duplicati.Server.WebServer.RESTMethods.RequestInfo info, System.String method, System.String module, System.String key) <0x41241480 + 0x00fc8> in <filename unknown>:0 

What can I try next?

This started working for me on Oct. 28/17 and I changed nothing. So, was this a server issue with the Duplicati oauth server?

The service is hosted on Google App Engine, so I have little control over it, but since it is hosted by Google, it is pretty stable. I do not see any abnormal amount of errors in the last 7 days.

If you want me to look into it, you can send me your IP in a PM and I can search the server logs to see if the requests made it into GAE.