Can't get 2.0.4.17_canary to work as service

#1

After running Duplicati for a few months, without any issue, I changed it to run as a windows service.

After a few attemps of getting it to work again, I just can’t succeed.

After deinstallation of the service and the application, and a new install, the backup profile keeps active.
I do not understand where this profile is stored, or how to remove it.
The webinterface, keeps showing Error!
And is impossible to stop, as I keepon getting the question “stop after the present file”, “stop now” or cancel
Clicking either stop now or after this file, it just wont appear as anything is happening, I’ve waited awhole day, and still no change.
I made a backup of the profile, so I just want to start with a clean install, and just load the profile from file
But there’s just no way of getting it to work again.
Installation steps:
I downloaded the last release from github, and executed it
I didn’t include start automatically, and didn’t started it after the installation, as suggested on the forum.
Than followed the YouTube video of Kees-Z and installed duplicati as a windows service
Started the service and browsed to http://127.0.0.1:8200/ngax/index.html and there was the old profile.

I cleanded the service after deinstallation, and the reigstry, and local files folder as well as the folder in program files.

I could need some guidance on how to get this to work again.

#2

Sorry I’m quite lost in the profile references as to which is which.

Was this a reinstall of the service, or just the ordinary GUI install?

Which one? You couldn’t find the other one. Which one was this?

What does this mean? The backup, job exports, something else?

Which profile is this? Maybe you can give names to your profiles. “Old” could mean any mentioned earlier.

If you followed Duplicati Tutorial 02 Install Duplicati as a Service closely, it has you use --portable-mode so profile is (I think) in C:\Program Files\Duplicati 2\data". If you didn’t use that, I think profile will wind up under C:\Windows\System32\config\systemprofile\AppData\Local\Duplicati which is the profile for SYSTEM user and is rather protected. You can open a command prompt as Administrator if you want to get to that folder. Ordinary user profiles (without --portable-mode) follow a similar convention and reside in the user’s profile C:\Users\\AppData\Local\Duplicati (AppData is a hidden folder. Change File Explorer setting to see those).

The second thing you might be running into is the way things look in the web UI, and this can be confusing when you have multiple Duplicati running (for example one as a service and another not as a service) as a Duplicati (at least the TrayIcon version – I’m not totally sure about the standalone server) move upwards to a different port if ports are already taken. So you could have a Duplicati at :8200, and another one at :8300. Unless you really like or need this, life is less confusing if you never have more than one Duplicati, at 8200. Possibly this is what you meant by “keeps active”, or do you mean you infer activity from other indications?

Duplicati components
Introduction to the Graphical User Interface

Migrating from User to Service install on Windows is kind of lengthy, but might give you helpful information, and I hope some of the above is also helpful even though I’m not totally following what you’re wanting to do. Usually a migration where old settings and jobs are used is a good thing, but you wish to reload somehow.

1 Like
#3

Hi ts678,

Sorry for the confusion.
I started out with a regular installation of duplicati, and made a backup profile called “My Backup”.

Than I learned about the service method, and switched over.
I made a backup of the “My Backup” profile, and stored it for save keeping.

Now the “My Backup” profile, keeps being present, even after multiple uninstalls of both service and application, and cleaning of the registry.

I just want to start with a clean and empty installation of the windows service without the “My Backup” profile, as it keeps blocking further usage of the application.
And then load the profile “My Backup” from the stored file.

I did not use the “–portable-mode” because I want to store the data/database on a different drive than the system drive.
And there was the clue to why my old profile keeps poping up:
" If you didn’t use that, I think profile will wind up under C:\Windows\System32\config\systemprofile\AppData\Local\Duplicati which is the profile for SYSTEM"
I now removed that folder too.

Now starting the browser shows me that no profile is loaded.
I add a new backup, and import the stored profile.
After a few seconds the status fields shows “error!” and I’m back to where I’ve started.

So what I want to do is, start with a clean windows service for Duplicati
Use the websrowser for settingup/controlling backups
Reuse the data allready in the backup loacation (100GB+) and start to backup again.

I think the browser GUI should be more informative, like showing what the application is actually doing right now.
Maybe it is generating a catalog of the online data and will take (quite) a while doing so.
But for me at this moment it just seems like it’s doing nothing than being unusefull.
I’ve read about this development wish a few times in the forum by others too.

Just to add this as a side note:
I really love the application, which has always worked like a charm, and want to thank everyone involved for it and the support.

#4

I ended up with deletion of the backup files from the storage, and than the backup ran again.

#5

The next server has the same issue.
The only thing that had changed was that I’ve added the MS SQL server databases.
This server has almost 500 GB with backup data, So I really do not want to delete the remote backups.
Any other thoughts with this new information?

#6

Could you please clarify “next server” and “same issue”? It sounded like you had one server that was fine.
Is “next server” a different Duplicati installation, or the one that was running as of previous post on May 2?
Which of the previously reported issues is “same issue”?