Can't access the web interface from network this time "LinuxServer"

Hi guys,

About 6 months ago I’ve installed Duplicati on my headless Centos 7 box with simple installations steps I’ve found in an article online (for the life of me that I cant find the article again), it ran flawlessly. Recently I had to re-imagine the machine and today I went back to install it again and first I can’t find specific instructions in the manual for CentOS 7 / RedHat, everything is for Ubuntu so researching from many old articles in the web I were able to install it mostly using this instructions: Headless Duplicati on CentOS (Guide) - Wikis & How-to Guides - Level1Techs Forums

But there is no way for me to access the web interface on http://machineip:8200 from my Windows PC using Chrome.

  • Of course I can ping the box, Im ssh’in using Putty.
  • I thought that maybe needed Apache installed so i did and I can access Apache welcome page
  • I can access my Plex server which runs on :32400
  • Disabled the firewall
  • Restarted the services a couple of times
  • Rebooted the machine
    annnd nop, can’t access it. I ran “systemctl status duplicati.service” and this is what I am getting:
    duplicati.service - Duplicati Backup software
    Loaded: loaded (/etc/systemd/system/duplicati.service; enabled; vendor preset: disabled)
    Active: active (running) since Thu 2020-09-10 12:11:41 MDT; 41min ago
    Main PID: 10796 (mono)
    CGroup: /system.slice/duplicati.service
    ├─10796 DuplicatiServer /usr/lib/duplicati/Duplicati.Server.exe
    └─10800 /usr/bin/mono-sgen /usr/lib/duplicati/Duplicati.Server.exe

Sep 10 12:11:41 localhost.localdomain systemd[1]: Started Duplicati web-server.
Sep 10 12:51:20 localhost.localdomain systemd[1]: Current command vanished from the unit file, execution of the…med.
Hint: Some lines were ellipsized, use -l to show in full.

I ran a port scanner and noticed that the machine is not showing the port 8200 open, only have open 22,80,139 and 445 so, the installation of Duplicati should have done that or is another step that is not documented anywhere? but is weird because Ive re-check and the firewald is NOT running. I dont have any firewall in my internal home network.

I will appreciate any help, kind of desperate at the point to decide to run Duplicati on Windows :frowning:

Thanks in advance.

Hello and welcome to the forum!

By default Duplicati only listens on localhost, so it’s not accessible from the network. I looked at that guide and see where they have you set --webservice-interface=any in the systemd service config. Are you sure you didn’t miss that step? After making that change you’ll need to restart Duplicati for it to go into effect.

# netstat -anp | grep ‘8200.*LISTEN’
tcp 0 0* LISTEN 14595/mono-sgen

can show if Duplicati got all interfaces or just your localhost:

# netstat -anp | grep ‘8200.*LISTEN’
tcp 0 0* LISTEN 8778/mono-sgen

Thanks for your reply drwtsn32,

I just re-check and have it exactly as the instructions

> --webservice-interface=any

This is exactly what I have in that file:

Description=Duplicati Backup software
ExecStart=/usr/bin/mono /usr/lib/duplicati/Duplicati.Server.exe --webservice-interface=any

Hi ts678, thanks for your reply.

I’ve tried both commands and (after install netstat because Centos7 dont come with it) I am not getting any output after run them.

Then I tried netstat -anp | grep 8200 and this is the output:

]# netstat -anp | grep 8200
tcp 0 0* LISTEN 892/mono-sgen

Oh gosh, all of the sudden now works, the only change I’ve made is that I upgraded my network last night to everything ubiquiti and the network IP changed from 10.0 to 192.168 and thats it (well, during that time the machines was turned off for hours). Ahh

Well guys, thank you so much for your quick help


Glad you got it working!