Cannot Setup New Windows OneDrive for Business Backup

I am trying for the first time to setup a backup to OneDrive for Business. First I tried it on the Mac using Duplicati - and it is currently running - seems like it is working. But when I try to run it on Windows 10 64 bit PC it refuses to connect (using the same settings as were used on the Mac). I compared the connection strings on windows and mac and made sure they matched using the “…” on the user interface. I used the format exactly. But each time it keeps on pausing on Windows for a long time and then showing "Failed to connect: No SharePoint web could be logged in to at path ‘’. Maybe wrong credentials. Or try using ‘//’ in path to separate web from folder path.
Is there is a bug in just Windows in the latest version when using OneDrive for Business? I tried using the windows latest canary version also and that did not fix the problem.

I believe Windows, MacOS, and Linux all done from the same codebase so the likelihood of an IS specific bug should be pretty low.

That being said, on Windows the .NET code runs “natively” while on MacOS and Linux it runs through Mono, so it’s possible there’s a difference between native and Mono based execution. Though if that were the case I’d expect the issue to happen on the Mono side…

When you get the"Failed to connect" message is that during a backup or at the"Test connection" step?

I get “failed to connect” during the test. But i get “element with path… not found on host” when i try to run it

If it fails during the test I’m not surprised it fails during the run.

My GUESS is an authentication error but if you try the test again, can you look at the details of the error in the Live Log?

same here - failing on one particular PC (Win 10 Home) with exactly the same error.
Perfectly working on two other PCs (Win 10 Pro, Win7), using exactly same logon/server/path settings.
Need to investigate further

Hi @BoGreen, thanks for joining the forum!

What version of Duplicati are you using and are there any errors in the logs after doing the test?

@JonMikelV thanks for the reply.
Version was latest as of yesterday, i.e.,Win 64bit
Still need to check the logs, yet so far I suspect some networking issues with that PC.
Will keep you posted.