Cannot access backup

I installed Duplicati on my Linux computer to back up to a NAS (Asustor) a couple years ago. That computer died and now I am trying to access the backup from a new computer (also Linux). When entering the info and ‘Test Connection’ it will not connect. I did a backup of this new computer to the NAS just now and it ran fine, but when I enter the exact same info into Restore, it fails to connect.

Add: If I in ‘Restore’ I chose the option of the Backup I created under Backup, it all works fine, but if I choose direct restore and enter the details as above, it doesn’t.

Here is some additional info. I can connect to NAS just fine with Filezilla and transfer files both ways. I did a successful new Backup and Restore from Duplicati, but I cannot access my old backup. I tried exporting the successful Backup configuration and then importing it to Restore, but when I try to run the imported configuration, I get "Failed to connect: The remote server returned an error: (451) 451 Transfer aborted. Broken pipe . "
Any ideas??

What is the error displayed by the software when you test the connection ?
about the error 451, it seems to be generated by the target system, is there any error in the logs of this system ? if not displayed in the Web UI, maybe there could be more information about the problem in the logs accessed through a direct (SSH) connection.

Here is the log of the last error:

target system == NAS
I was writing about the NAS logs.

Here is what I found:

Note: SSH is enabled.

The system log don’t hold the solution to your problem - it’s quite obvious that you exposed your NAS to the Internet and there are login attempts to hack your NAS. Nothing to bother you if you have set a complicated password, or enabled 2FA (personally I’d not expose a NAS to the Internet for SSH access but it’s your call)

Anyway, if the system log is useless, maybe there is another log that could be more interesting ? There is an arrow to the right of ‘System log’, did you look at other logs ?

Other logs are connection and file access. Unfortunately there are no entries in the File access and the Connections are all me.

Then my guess (note that I have never used your NAS brand so I may be wrong) is that to access the ftp logs, you need to connect to the NAS through SSH.

I’ve never used SSH, but I’m sure I can find a you-tube on it. I’m thinking I may just try copying the files to my USB HDD using Filezilla and then using Duplicati with the ‘local file’ setting.

To begin with it on Windows the usual process is to download and install Putty:
https://www.chiark.greenend.org.uk/~sgtatham/putty/

then you enter the server name or IP address, the user name (usually ‘admin’ for a NAS), the password and you are usually (after agreeing to a certificate approval) in a console window, from then it’s more or less a Linux admin task. Logs are usually accessed by
cd /var/log
and then listing the log files with ‘ls’ and looking at the content with a Linux editor such as nano or vi (I have no idea on what could be available on your brand of NAS).
On second thought, you can probably do the same thing using a sftp tool such as Filezilla.

Apparently Duplicati puts some kind of lock on the backups as I could not move them to an empty USB HDD with Filezilla although I could move other files on the NAS.

I take that back. Apparently Filezilla had crashed. I closed a d reopened it and now it is copying the files over. I’ll let you know if I can then open them.

One problem solved, another created. I finally moved ALL of the backup files to a USB HDD and I can access that with Duplicati:


However, on the next step, I get:

Forever. Nothing ever happens.
What now??

Please see what’s happening at About → Show log → Live → Verbose (or Profiling if Verbose is quiet)

I’m not sure what happened. I think I was just not patient enough. I tried the same Restore this morning and it worked! It took 15-20 minutes on some steps (recreating the database and finding files) but I walked away and when I got back the Duplicati reported success and indeed the files were all there.
Thanks for your help. We can mark this ‘solved’

1 Like