[bug] Download -> Activate -> crash

That sounds fairly similar to my experience except I didn’t try reinstalling the beta in either case - every time it’s happened for me i’ve gone ahead and downloaded the .msi for the canary version in question (the one that supposedly installed correctly), running the install again, and allowing it to launch - and it works properly after that.

This most recent time I tried rebooting first to see if it would launch, and as in your case, it never did (i didn’t check services but I expect it would have been as you’ve reported); but after manually running the canary .msi as I said above, it is currently running fine.

Yep, install of duplicati- seems to have gotten things going again!

Though somewhere along the line I screwed something up as it’s telling me I’m running canary but that there’s an update available for canary.


1 Like

I got that once after restarting, but dismissed it and don’t seem to be getting it anymore (but i haven’t tried restarting again either).

Is this because you are running with a service?

I think there is a problem with the service not updating correctly, so you have a half-updated installation. Could this explain the updater problems?

I haven’t done anything to deviate from the normal default install created by the .msi installer (running windows 10 on my work laptop, 8.1 on my home PC). Sorry for not being sure whether that means it’s running as a service or not :-/

In that case you are not running as a service :slight_smile:

It looks from the crash messages that there is some problem with the “app domain” approach, where some types are not correctly shielded. Terrible thing to debug :tired_face: .

The one thing that smelled fishy to me (but may not be an issue at all) is, when using the regular installer, i get the UAC security popup from Windows, and the auto-updater has no such authorization. I don’t have any extra high security settings or anything within windows, just the routine stuff, if it makes any difference.

For me I got the issue with my non-server install on Windows 10. I also do but recall getting a UAC prompt during upgrade.

I do have a Windows 10 server install of beta on another machine I’m playing with so let me know if you’d like a canary update test in that environment.

I designed the updater to not require elevated permissions. It simply finds a place where it can store the new version. The original version then finds this and does a “bait-n-switch” starting the updated version. This allows updating without fiddling with UAC or interfacing with the MSI stuff.

Ok - that makes sense but wanted to point it out just in case. As you can see from the video I posted before, the install process does appear to run correctly up through the “activate” phase.

Hopefully this isn’t considered a hijack, but since it hasn’t been mentioned yet, I thought I’d share that I had no issues with a test install on Ubuntu Linux going from beta to

HOWEVER - I did notice these oddities in the UI:

  1. After setting “Update channel” to Canary, the “About” page showed (bolding added by me):

You are currently running Duplicati unknown
Update is available, download now
Check for updates now

  1. On the “Settings” page when testing going from Canary back to beta, the “Update channel” showed (bolding added by me):

Default (Canary)
Same as the base install version:

I tried a reboot in case there was something left over from the update from beta to canary but it still showed the same message and doesn’t find any “updates” from back to

1 Like

For what it’s worth, the issue appears to persist even with the current canary build - I attempted to use the auto-updater to update my laptop this morning and after clicking “activate” it never bothered to start up again.

Seems to be the same issue as this:

1 Like

I’ve seen that (since this thread was linked from there some days ago) – the issue does seem similar though of course I don’t have the confidence to say for sure since I’m not running duplicati as a service, and I don’t know exactly what difference is implied by that.

FYI, i noticed there was some update in today’s canary (.11) to address the auto updater. So I manually updated to .11 (using the downloaded MSI etc), then ran auto-updater to .12 – i didn’t receive any crash, but duplicati never launched again after .12 was installed. However, unlike previous auto-update attempts, I was able to launch it manually (previously it would close itself within a second or so, and/or throw a windows crash message). So it seems like we’re on the right track :slight_smile:

1 Like

FYI (@kenkendk), the current canaries behave similar to how I described in my last reply when doing an update - the install seems to happen correctly, but the application never re-launches at the end (it works fine after I manually launch it again). Is this the expected behavior currently? (Windows 10, latest update, current canary, etc).

No, certainly not the expected behavior, it should just relauch the process. But at least the new problem is easier to work with than the old one :smile:

1 Like

I’m now attempting to upgrade from to…

The GUI finds the new version and offers the “Show / Install / Dismiss” prompt as usual. When I click “Install”, it downloads and shows the download progrss bar… but now, the button bar just changes back to offering the same options - and if I click “install” again it begins the download over again. Repeat 4-5x so far and I’m concluding this is a legit new bug.

Confirmed. Exactly the same symptoms for me on multiple installs.
I fixed it by stopping the Duplicati service and overwrited the program folder with the Zip version of

1 Like

I just noticed that my attempts to use the auto-update function was throwing these errors to the general log: