Backup Warnings - The supplied option --auth-password is not supported and will be ignored

I have started getting the below error everytime I run my backup jobs. I use google drive for storage and that uses the API key for auth.

I’ve had a look through the settings and can’t see a hidden advanced setting anywhere.

  • 2019-08-03 12:00:00 +00 - [Warning-Duplicati.Library.Main.Controller-UnsupportedOption]: The supplied option --auth-password is not supported and will be ignored

Firstly, does this affect the backups at all?
How do i diagnose what is causing this?

Running version You are currently running Duplicati - on ubuntu 18.04

Creating a new backup job has pictures that also apply to Editing an existing backup.

On screen 2 Destination look for Advanced Options and open it. If this option doesn’t show up in the default “Edit as list” (and it might not, because it doesn’t apply), try the three-dot “Edit as text” option. Delete option. Possibly this option is a leftover from a previous configuration. Remember to Save on screen 5 when done.

Because it says “will be ignored”, it should not. If you’re getting in fine and backing up, then it did as said.

Try to trace where the backup came from, e.g. did it ever use a Storage provider where --auth-password made sense? Changing the storage provider type sometimes does not clear out all the previous settings.

If you believe this happened all by itself, or on upgrade from earlier canary, that would need further history. These options are in the Duplicati-server.sqlite database but unless you saved history, it’s just your recall.
EDIT: Your backup logs or emails might help find when they started, then you can try to remember history.

Sometimes database format upgrades will save history, but it’s some trouble to look through backup files.
The sqlite package (DB Browser for SQLite) should be able to open any SQLite files you find laying there.

These are all recently setup backups (last two months) and have only ever used Google drive as a destination

Only happened since I upgraded to the latest canary release in the last few weeks.

No visible option under advanced settings

Only started recently as a multi terabyte backup finally finished so the others started running on their schedules

Can you see an Advanced options section and three-dot menu if you start to configure a new backup, e.g.

If you see “Advanced options”, look for the same in actual backup, and try three-dot menu to “Edit as text”.
There’s not supposed to be a need to refresh browser, but maybe it needs one, so you could do a Ctrl-F5.

Duplicati keeps changin Backup Name is another possibility (though it seems unlikely) where the browser autofill or password manager add things without your typing them in. Still need to find where it came from.

One way to see where it’s sitting now would be to use the “Backup destination” three-dot menu to copy to clipboard, and see if it’s attached to the URL with an ampersand. Or it might be a standalone option which Commandline option would reveal. It also shows “Target URL” so you can see the URL that way if you like.

Exporting a backup job configuration As Command-line would be another way to see URL and options that might either be ampersand-attached, or possibly standalone, e.g. an --auth-password seen in your export.

Do you recall what release you had before that canary (which was my screenshot on Windows Chrome)?
v2.0.4.22- would have likely been your latest canary, and prior canary (if you were on canary channel and installing updates) would have been v2.0.4.20-

If you get emailed backup reports, you might be able to get the version history from lines like the following:

Version: (

sorry for the slow response.

Can confirm, for one of the jobs that I get the warning with there is no --auth-password in the config (i have tried both the 3 dots and exporting the configurations to json

from the json here are the options

  "CreatedByVersion": "",
  "Schedule": {
    "ID": 7,
    "Tags": [
    "Time": "2019-08-20T23:00:00Z",
    "Repeat": "1D",
    "LastRun": "2019-08-19T23:00:00Z",
    "Rule": "AllowedWeekDays=Monday,Tuesday,Wednesday,Thursday,Friday,Saturday,Sunday",
    "AllowedDays": [
  "Backup": {
    "ID": "3",
    "Name": "USER_DATA - DAILY",
    "Description": "Backup of user_data folder on NAS VAULT101 on a daily basis. \nRetains 1 year of changes\n\nLast updated: 20/03/2019",
    "Tags": [],
    "TargetURL": "googledrive://USER_DATA-DAILY?allowed-ssl-versions=Tls12",
    "DBPath": "/root/.config/Duplicati/71687673808575776781.sqlite",
    "Sources": [
    "Settings": [
        "Filter": "",
        "Name": "encryption-module",
        "Value": "aes",
        "Argument": null
        "Filter": "",
        "Name": "compression-module",
        "Value": "zip",
        "Argument": null
        "Filter": "",
        "Name": "dblock-size",
        "Value": "350MB",
        "Argument": null
        "Filter": "",
        "Name": "--zip-compression-level",
        "Value": "9",
        "Argument": null
        "Filter": "",
        "Name": "--use-block-cache",
        "Value": "true",
        "Argument": null
    "Filters": [],
    "Metadata": {
      "LastErrorDate": "20190803T080151Z",
      "LastErrorMessage": "Found 7 files that are missing from the remote storage, please run repair",
      "LastBackupDate": "20190810T230000Z",
      "BackupListCount": "9",
      "TotalQuotaSpace": "16795620857632",
      "FreeQuotaSpace": "10995116277760",
      "AssignedQuotaSpace": "-1",
      "TargetFilesSize": "1574247187877",
      "TargetFilesCount": "8601",
      "TargetSizeString": "1.43 TB",
      "SourceFilesSize": "2001312463686",
      "SourceFilesCount": "457159",
      "SourceSizeString": "1.82 TB",
      "LastBackupStarted": "20190819T230000Z",
      "LastBackupFinished": "20190819T234201Z",
      "LastBackupDuration": "00:42:01.4243230"
    "IsTemporary": false
  "DisplayNames": {
    "/mnt/user_data/": "user_data"

Weirdly, I do not get the error on all of the jobs yet they were all created on the same date.

This is the only difference between configs that have the error and ones that don’t.

Not sure what this option does or where it came from in the other configs, any clues? Would this be causing the issues?

–use-block-cache creates a block lookup cache in memory to avoid DB. An early test didn’t see much gain. Seems pretty far removed from passwords, but you can certainly try removing it to see if it helps that issue.

As a note on exporting to JSON, this won’t pick up global options from Settings, so look there, or instead do Export As Command-line or Commandline to get a better view of what your backup would actually be using.

removed “use-block-cache” and still get the warning.

I also exported the command line option and the option isn’t there either. Also, if it was a global option surely all backups would show that error?

Anywhere else I can look to help diagnose this?

–auth-password is not supported has some things not yet tried (e.g. password manager) and some tried.

DB Browser for SQLite can look in the Duplicati-server.sqlite database Backup and Option tables for that.
Windows DB (only) is obfuscated, so TrayIcon (or what you run) will need --unencrypted-database option.


You can also take the Export As Command-line and try it in a command line. This won’t use the Duplicati-server.sqlite DB (or feed result statistics back onto the home screen). It’s a very independent operation…


Depending on destination, it’s a necessity not an error. I don’t know what destinations you’ve used before.

I run duplicati on its own ubuntu VM. Will grab a copy of the DB and see if I can find anything in there

The only destination I have ever used for any of the backups is google drive. All set up at the same time using the this destination.


Have just exported to command line and ticked export passwords and the -auth-password option is showing up.
Is there a way to remove it? I have tried editing the job but i don’t see anywhere for the field (even to be auto filled) and I don’t want to have to recreate the backup as its a multi terabyte backup on a slow connection (took a few months to upload)

Is this an empty option (e.g. nothing --auth-password= with nothing to its right), or an actual password?

While I could see a remote chance of Duplicati inventing options out of nothing, right password isn’t likely.

C:\Program Files\Duplicati 2>Duplicati.CommandLine.exe help auth-password
  --auth-password (Password): Supplies the password used to connect to the
    The password used to connect to the server. This may also be supplied as
    the environment variable "AUTH_PASSWORD".

C:\Program Files\Duplicati 2>

is another way for passwords to get in. –parameters-file might do it too, but I’m not sure Export reads it.

Typically I think people just use the default GUI flow and the password winds up in Duplicati-server.sqlite, where it could be removed, but I’d hope it’s also in the UI somewhere (including places in the link I cited).

Possibly some option filtering occurs, so you don’t see --auth-password unless it’s valid for that storage.

There seems to also be some ambiguity over where passwords live. Sometimes they’re on Target URL, attached with semicolon. Other times they’re presented as standalone options. Which place is yours at?

Commandline gives a clear split between Target URL and options. GUI job edit is two part but less clear:

it contains a password and it is the password I use for the web interface.

mono /usr/lib/duplicati/Duplicati.CommandLine.exe backup "googledrive://USER_DATA-DAILY?authid=<AUTH ID>&auth-password=<WEB INTERFACE PASSWORD>&allowed-ssl-versions=Tls12"

This seems to be the case as there is no field I can see for this password to entered or removed

When i do edit as text this is the only option i have


How is “Backup destination” “Copy Destination URL to Clipboard” and Commandline “Target URL” box?

I’ve edited the job and by toggling the destination back to “Local folder or drive” I can see the password field filled in.

I have cleared this field and set the destination back to google drive and when exporting to command line the option no longer shows up.

I’m guessing it must have been an auto fill when I created the job although weird it didn’t autofill on all jobs created.
Was there an update in the most recent canary to start showing these warnings?

v2.0.4.22- release notice is not speaking of one, and neither is source archive:…v2.0.4.22-

Weird as the warnings only started after that update.

Thanks for your help, finally managed to figure out what was causing them!

1 Like

A very similar argument is attached to a Dropbox destination URL (dropbox://?authid=xxx&auth-username=yyy). I could remove it using an sqlite editor. I opened .config/Duplicati/Duplicati-server.sqlite and deleted the auth-username=yyy part from the TargetURL field in the Backup table.