Backup to mega.nz stuck at “Waiting for upload…”

It’s a few days that my backup jobs to mega.nz hang on the “waiting for upload” step. Every time I need to stop them manually because otherwise all other jobs cannot be executed.
I’m running Duplicati - 2.0.3.9_canary_2018-06-30.
I’ve searched about a solution in the support forum but found nothing definitive. In a thread (HELP Backup to Azure fails at “Waiting for upload”) it is suggested to split the backup job in several smaller ones, but I don’t think this proposal is convincing in my case. One of by backup jobs to mega.nz has a source data size of about 17Gb, and a backup size of about 15Gb with 4 versions. Not a very big size I think. Haven’t had any problem (about stuck at “waiting for upload” step) until last week.
Is there any other suggestion, apart from quit to backup to mega.nz? Previously I had to renounce to box.com, and I fear that with this problem I had to renounce to all my cloud destinations.

You’re not alone - a few other users have reported issues with Mega.nz lately (see below). Something that worked for a few of them was to make sure to set --upload-verification-file=false.

I had a similar issue with box.com where it appears they are fine with an initial upload but replacing an existing file causes a problem.


Thank you to point out the other threads. I regret to not having found them.
Your suggestion to set --upload-verification-file=false solves the issue.

By the way, why the sign in the progress bar shows a negative file size?


Thank you again.

The negative file size in the progress bar is a known bug with version 2.0.3.9 canary. We hope to have it fixed soon, but until then if it’s a problem consider downgrading to 2.0.3.5 (which is also a more stable version).