Backup task not creating new log, showing old errors

I have a backup task that has been working fine for a long time. Today it failed due to some files being locked. I edited the backup to exclude those files, and now it doesn’t seem to work properly. When I manually trigger it I get the old errors and old log again.

The backup was started at around 15:10, but you can see that the log is for the failed one from 14:00.

I get the pop-up warning message and red taskbar icons.

OS: Windows 8.1 x64

I tried the usual stuff like restarting Duplicati (making sure that it closed in Task Manager too) and closing the app that had locked the files in question. I tried running a different backup and that completed without any errors, and created a log with the correct timestamp.

I tried a verify and then a repair command, both returned the old error due to locked filed. The drive with Duplicati on and the log files has plenty of free space.

Any ideas on how to fix this?

your exclusion has probably a syntax error leading to the job aborting early. Try to remove it.
By the way, a better way to handle locked files is to setup Duplicati as a service and enabling shapshots.

1 Like

Thanks for the suggestion, I tried removing those exclusions and it made no difference. They were created with the web UI.

I have no brigher idea then, I’d suggest to export the job as a command line and paste the result in a console window to see more about what is happening. If you don’t run Duplicati as a service it should be good to go without using a special admin console.

I tried the console, this was the output:

Backup started at 14/06/2022 16:16:06
Checking remote backup ...
  Listing remote folder ...
  Listing remote folder ...
  Listing remote folder ...
  Listing remote folder ...
  Listing remote folder ...
Fatal error => The system cannot find the file specified

System.ComponentModel.Win32Exception (0x80004005): The system cannot find the file specified
   at Duplicati.Library.Main.BackendManager.List()
   at Duplicati.Library.Main.Operation.FilelistProcessor.RemoteListAnalysis(BackendManager backend, Options options, LocalDatabase database, IBackendWriter log, IEnumerable`1 protectedFiles)
   at Duplicati.Library.Main.Operation.FilelistProcessor.VerifyRemoteList(BackendManager backend, Options options, LocalDatabase database, IBackendWriter log, IEnumerable`1 protectedFiles)
   at Duplicati.Library.Main.Operation.BackupHandler.PreBackupVerify(BackendManager backend, String protectedfile)
   at Duplicati.Library.Main.Operation.BackupHandler.<RunAsync>d__20.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
   at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
   at CoCoL.ChannelExtensions.WaitForTaskOrThrow(Task task)
   at Duplicati.Library.Main.Controller.<>c__DisplayClass14_0.<Backup>b__0(BackupResults result)
   at Duplicati.Library.Main.Controller.RunAction[T](T result, String[]& paths, IFilter& filter, Action`1 method)
   at Duplicati.Library.Main.Controller.Backup(String[] inputsources, IFilter filter)
   at Duplicati.CommandLine.Commands.Backup(TextWriter outwriter, Action`1 setup, List`1 args, Dictionary`2 options, IFilter filter)
   at Duplicati.CommandLine.Program.ParseCommandLine(TextWriter outwriter, Action`1 setup, Boolean&verboseErrors, String[] args)
   at Duplicati.CommandLine.Program.RunCommandLine(TextWriter outwriter, TextWriter errwriter, Action`1 setup, String[] args)

Is there any way to make it tell me what file it can’t find?

I’m afraid that there is no easy way…
The whole software industry is not geared to provide help for end users when somethng goes wrong (in case someone reads this and interprets it as a critic of this project, it’s not: usually the operating system and the tools used are the main culprits and when looking at the software with the purpose of changing it to make it spit out better diagnostics, I usually come to the conclusion that it would be very difficult to do without raising the total software complexity significantly - never a good thing by itself - IMO Duplicati has good error reporting but Windows and .Net are not helping there)

  • First approach: fiddling with the command line (remove non essentials parameters) until you see the program going further. I am NOT talking about the command line tool in the UI, but what happens when you paste the exported job in a console windows. This is a faster turnaround than trying parameters in the UI. It could work - or not.

  • Second approach: post the command line here and hope that someone else will have a lightbulb moment

  • Third approach: debug it yourself. The process monitor from SysInternals (well, Microsoft now) could be a way. But there is quite a learning curve. The idea is to start it just before you start the command line and to stop it when it fails, and then comb through the trace for failed system calls, usually highlighted in red if memory serves me. To limit the trace the usual way is to add a filter on the process name (else all processes are traced and it’s not so useful)

Looks like it is failing miserably when trying to validate the remote (destination) storage. Can you double check your destination settings in the backup job?

When a job fails completely, often there is no log attached to the backup job. That’s why you see an older log when you view the backup job history. It’s annoying behavior for sure…

1 Like

Thank you @gpatel-fr, that was the hint I needed. It’s been so long since I used it I forgot about Sysinternals Process Monitor.

Using that I was able to determine that Duplicati was unable to find the rclone executable. Because of recent issues with Jottacloud I had switched to using rclone until the fix is pushed out.

I did some more testing and have found a bug in the Duplicati web interface. If you edit a job that is using rclone, it discards the additional destination parameters you set up. In my case that was the path to the rclone executable. I can reproduce it every time.

Additionally, if you open a working job and look at the destination page, under advanced options nothing is listed even though the rclone executable path has been set and works.

I’ll report the bug. For anyone else, just remember to add back in your advanced options after making any changes to the backup job.

Issue here: Advanced destination options lost when editing a job in the web UI · Issue #4748 · duplicati/duplicati · GitHub

I think they remain if you put them on Options screen 5. Destination screen 2 seems to drop them.

Settings for alternate destination marker and -path are lost #4553

1 Like