Backup schedules disappeared

I’ve had duplicati running for a long time on our laptop without really keeping a close eye on it. When I recently wanted to check up on it, the Home screen is empty and no scheduled backups are listed. I’m not sure exactly what has happened.

I was backing up to backblaze’s B2 storage, and I can see the backup is still there and 21.1 GB and was created in June 2018 (I guess that’s when I started backing up from the laptop).

Looking at the local files in AppData I can see a backup 20190217100118.sqlite file of 116 kb and a Duplicati-server.sqlite also of 116 kb (There’s also a control_dir_v2 with a lock file in it). Does this sound like that could be the original database, or is it too small? I’m not sure how big the local database should be… If it’s been deleted, how would I best be able to get it back up? Should I just try to restore the original backup “on top of” local files (what would happen if any local files had changed since the backup last ran?

I can’t seem to see any errors in the logs through the web interface… I don’t know if there are some local log files somewhere that would be more likely to give me useful information?

Hope someone would be able to help :slight_smile:


Before you adjust database files, let’s see if we can figure out what happened. When you first installed Duplicati, did you configure it to run as a Service by chance? If so maybe what you’re seeing is a separate TrayIcon instance (which would have its own, quite possibly blank, configuration).

Look at the web UI again and note the address. Is it using “localhost:8300”? That’s an indication you are running 2 instances of Duplicati. Try checking “localhost:8200” to see if your configuration is there. (Or vice versa - if the blank config is 8200 try checking 8300)

1 Like


Have a look at my problem and the solution handyguy proposed . What you see is pretty much what I saw in the local system’s folder after Windows performed a major update on some of my systems! I was running Duplicati as a service. See here:

Hope this helps you as it helped me! :wink:


I just want to thank you for your replies and apologise for my slow responding. I’ve been busy at work and exploring a new city/home, and I’m not on that laptop on a daily basis. I hope to have some time to look at it this weekend. (I had already tried the other port number, though, and there wasn’t anything there).

If you installed Duplicati as a Window service (not done in .msi GUI, but by Duplicati.WindowsService.exe), please check soon to see if you have a C:\Windows.old, because Windows may delete that 10 days after upgrade, otherwise (such as no service install, or Windows version upgrade was long ago) there’s no rush.

1 Like

Ooh, I forgot to mention, the laptop is running Windows 7.

That likely rules out a recent version upgrade, and the Windows.old concern. Support ended Jan 14, 2020.
Interestingly, Windows 7 seems to have made it to .NET Framework 4.8 but maybe without new bug fixes.


I finally got to look at this again :slight_smile:

Seems like it is some sort of conflict between the “tray” and “service” versions of duplicati, maybe both running. However, there was nothing listening to any of the other ports (only 8200).

I checked the services settings, and I could see that there was a duplicati service and it said it was running. I tried stopping it and accessing 8200, and it was still responding.

Then I looked in the system tray and saw duplicati also there, so I quit it, and now 8200 stopped responding.

Then I went back to the services and started the service again and requested 8200 again, and now it responded and the scheduled backup is there. Also, I can see that it has been running successfully as recent as yesterday.

I’m not sure if there’s an easy way to remove the “tray” version, but not risk losing the setup of the services one. I can only see one “Duplicati 2” entry in the “Programmes and Features” settings.

Thanks for your help and Merry Christmas!


Yeah, the problem is you are actually running two independent instances of Duplicati.

Since your “service” version of Duplicati is the one that is actually configured, I recommend you remove the trayicon shortcut from your Startup folder. Alternatively, edit the trayicon shortcut properties so the command line has this added: --no-hosted-server. This will let you still use the trayicon but it will link up with the “service” instance instead of starting a new instance of the backup engine.

1 Like