Backup_ProcessingFiles does not end

I started a backup manual and it hangs at one file:


I waited one day and the state does not change. Any advise what I should do now?
I assume just stopping the docker image will result in a databank issue?

I would be glad, if someone can guide me handling this issue.

Best regards,

Everything that is being attempted for the other active report today, which seems to be basically:

If situation differs greatly, for example if you’re backing up to a remote, please describe the setup.
Some of the debug is admittedly getting pretty deep, but might as well look for similarities in them.

One significant difference is you’re not on Windows. How does that iPhone fit into the file picture?
Are the photos just sitting on local disk (what OS?) at this point, or is something “live” being tried?

For Docker (whose image?), OS is probably Linux, and the debugging environment typically poor.
Docker containers tend not to have many tools in them, but at least there’s a command line to try.

You can get whatever you can out of the Duplicati GUI though, such as About → System info data.
As noted in the other issue, kills and other hard stops are sometimes risky but sometimes needed.

You should be able to get the log files because you probably have some access to host filesystem,
however I assume we’re not as sure that problem is repeatable compared to the other issue, right?


Your backup history and historical knowledge (and maybe a look at the file’s timestamps) should be
enough to take a guess as to whether file that is seen seemingly not being read has worked before.
When you get Duplicati back to working shape (preferably after getting info), Restore will help know.

Hello ts678,

are you one of the developers from duplicati?

Duplicati is running in Container Manager from Synologs DS220+
I did the following actions so far:

  1. stopped image
  2. restart image
  3. remove file which causes issue from backup
  4. restart backup
  5. same issue with another file after some minutes

I tried this several times with other backup configurations.
Also repair and recover of database.
Always the issue, independent of the file.
Since I added 360GB to an existing Backup maybe this is the root cause!?
I deleted the complete backup with all files and create a new backup job.
This backup job is now running for 30 minutes without issue so far. I will give you an update if this time everything works fine. From my point of view this maybe a software issue.

Best regards,

Not really, although I did modify a line one time, and can sometimes figure out what the code is doing.

means (I think) that you’re not using an image made by the Duplicati developers. It’s by someone else.
Ability to debug images we didn’t make, on systems we don’t have, is sometimes limited. We can try…

On that, I’ll say that I don’t use Docker and don’t have Synology, but there are others who might help…

Often the support or development volunteers can’t help without your help, so please answer questions.

Hi ts678,

thank you very much for showing me, which duplicati image is from the developers. I will now use this image. I check backup again and give feedback if it works or if I have any further issues.

Best regards,

It might not fit Synology. I don’t know. Sometimes things are set around the needs of certain systems. Docker provides a little bit of insulation, but not complete, especially when integrating with things like “Container Manager” which possibly has some expectations around the containers that it manages…

Maybe somebody with a Synology will help out by saying whether it can run any Docker you can find. Maybe you know, as you have a Synology? This might not even be Docker related, but it’s not known.

What’s known is that enormous numbers of backups don’t have a problem like this, yet yours has one. Debugging is necessary, and because this isn’t easy to cause, your testing and data are the only way.

Or maybe you’ll get the Duplicati image up, and it will do better. I don’t know, but please say if it does.