Backup job finished - or not?

I have a scheduled backup job. After the last backup was due, I noticed that the time stamp of “last successful run” did not update. I tried to start the job manually with “run now”, but nothing happened.

I then restarted the server. The job did not start automatically, but it was possible to start with “run now”. The progress bar showed some activity and finally it showed “finished”, but the time stamp was still not updated. Manual run is not possible, again. Also other options like “Verify files” or “Compact now” are not available.

The log file shows no error and not even warnings.

Any idea what the issue might be? Additional information needed?
Thanks a lot!!!

Hi @T-6, welcome to forum. What version of Duplicati are you running and what platform? What’s your source and destination targets?

Hi @samw,
version is 2.0.2.1_beta_2017-08-01 running as plugin in Openmediavault on amd64. Source is local drive and destination is WebDAV on pCloud.

OMV runs on Debian, which version of mono are you using and have you tried different versions? Also can you please try to run your backup from the command line (shell) and provide the output.

MonoVersion : 4.6.2

I have not tried other version.

Can you run it from shell and add the --verbose switch. I’d prefer if you’d use putty and log to file so that I can look at the output.

how do I create the command? From GUI using “run backup command now”?

From that screen the output will be captured by the webserver. From the GUI, Configuration > Export > As Command Line. Then just copy, add the --verbose switch and run it from the installation path.

strange output:

Backup started at 27/12/2017 16:10:44
Invalid type Microsoft.WindowsAzure.Storage.Blob.BlobEncryptionPolicy for instance field Microsoft.WindowsAzure.Storage.Blob.BlobRequestOptions:<EncryptionPolicy>k__BackingField
Invalid type Microsoft.WindowsAzure.Storage.Queue.QueueEncryptionPolicy for instance field Microsoft.WindowsAzure.Storage.Queue.QueueRequestOptions:<EncryptionPolicy>k__BackingField
Invalid type Microsoft.WindowsAzure.Storage.Table.TableEncryptionPolicy for instance field Microsoft.WindowsAzure.Storage.Table.TableRequestOptions:<EncryptionPolicy>k__BackingField

Yeah, it is strange. Can you provide the actual command. Don’t forget to remote sensitive info like dest, passwords, etc.

mono "/usr/lib/duplicati/Duplicati.CommandLine.exe" backup "webdavs://webdav.pcloud.com:443/...&auth-password=..." "/media/.../" --backup-name="pCloud" --dbpath="/root/.config/Duplicati/...sqlite" --encryption-module="aes" --compression-module="zip" --dblock-size="50mb" --passphrase="..." --skip-files-larger-than="900MB" --send-mail-to="..." --send-mail-any-operation="true" --send-mail-body="%RESULT% Backup has been completed" --exclude-files-attributes="temporary,system,hidden" --disable-module="console-password-input" --exclude="/media/.../" --exclude="/media/.../" --exclude="*OneDrive*/" --verbose

Caused by --exclude="*OneDrive*/" ?

removed the path to OneDrive instead of using
--exclude="*OneDrive*/

Did not change anything.

Not sure if it’s related, but version 2.0.2.1_beta_2017-08-01 had an issue where “Finished!” was displayed before the job was actually finished. In fact, there were some expensive database operations that were still in progress.

See Database locked even when UI says Finished! · Issue #2803 · duplicati/duplicati · GitHub

Does not look like this. CPU and eth load is very low.

@JonMikelV, do you have an idea?
Thanks

Regarding the Azure EncryptionPolicy errors, not a clue.

For the “finished or not” issue, @warwickmm is correct that in 2.0.2.1 beta there was a database cleanup (I think) step that occurred AFTER the “Finished!” message was displayed.

The best way to tell what (if anything) is currently running and what’s queued up is probably to go to About -> System Info then scroll down to “Server state properties”. In there you should see:

  • activeTask is the ID of the currently running task (if any)
  • proposedSchedule is the “not yet in queue, but expected to be put in queue at …” list
  • schedulerQueueIds is the list of items CURRENTLY in the queue

My GUESS regarding the OP is that you were in the finished-but-not-really hole (which should have shown in the activeTask line) and when you tried to manually do things like run, verify, or compact they were being added to the queue (which should have shown on the schedulerQueueIds line).

Of course that’s assuming "Verify files" or "Compact now" are not available means you clicked on them and nothing seemed to happen…

This is absolutely bizarre. I have no idea why it would do this. I’m sorry, but I have no further input to your problem. One last thing I would suggest is to try creating a test job with a small set of data using the same settings and see if it still reports the problem.

This is what the server state properies report:

activeTask : {"Item1":2,"Item2":"6"}
proposedSchedule : [{"Item1":"6","Item2":"2017-12-31T00:00:00Z"}]
schedulerQueueIds : []

What are “Item1” and “Item2”? Are these backup jobs? Then “Item2” would be the one to pCloud, because it is scheduled to be done next on 2017-12-31. But, in that case, what is “Item1”?

That is what I meant.

I removed and installed Duplicati. But the backup job is still there and also the PWD for the GUI was already set.

I did a purge before the install.

Where does Duplicati store the configuration? How do I remove the configuration for backup jobs and PWD?

Have you tried the most recent canary build?