Backup job disappeared, remote files intact (Synology, Docker)

Hi all.

I installed Docker on my Synology NAS and used it to backup about 200GB to S3 Deep Glacier. The backup job appears to have worked perfectly (I can’t actually confirm because the end-of-backup job status check doesn’t work with Deep Glacier since you can’t actually instantly retrieve files immediately after storage). I did not set backups to be automatic (this is a folder that will change about once a month, only by adding files, never by editing or deleting). I suspended the Docker container, which is what I normally do given Synology’s pretty severe RAM and processor limitations.

Today, a few weeks later, I restarted the Docker container and opened the Duplicati UI only to see… the job is no longer there.

So, my questions are:

  1. Where should I look on the NAS/Docker volume to see if the backup job’s metadata still exists?

  2. Is it possible to restore the job’s metadata by pointing to the S3 bucket without restoring the actual backup

  3. Is it possible to restore the backup from S3 without the job’s metadata?

Given the difficulty of actually removing data from Deep Glacier I’d prefer not to have to re-run the process again, so hopefully I’m not hosed here. Thanks.

Hello, I also run a Duplicati docker container on my Synology so hopefully I can help. First, are you using the standard Docker GUI app in DSM? Or are you using docker command line stuff?

Can you tell me what you mean by “suspended” the Docker container? Do you mean you just stopped the container? Stopping doesn’t cause any issues (as long as you don’t do it while Duplicati is running a job of course).

Did you use the “Reset” command on the container by chance?

1 Like

I’m using the standard Docker GUI app, no command line stuff. I’ll attach screenshots of the relevant settings

Ah, yes, by suspended I meant toggling the stop switch in the Docker GUI. Made sure the job was complete before doing so. Did not use the reset command on the container.

I feel comfortable SSHing into the NAS so if there’s anything you can think of that’s worth trying I can do that.

Ok, Reset would clear the contents of the container but since you are properly mapping /data to your host NAS, even that wouldn’t have caused any harm. (I was just afraid maybe you hadn’t set up the volume mapping and did a Reset!)

No problem using the Stop command/toggle switch.

I’m not sure what happened though. Any chance you changed the /data volume mapping after your first backup? Or deleted anything in the docker/duplicati folder on your NAS?

Can you try creating a bash shell and running this command:

ls -l /data/Duplicati

1 Like

Thanks for the quick reply. I don’t think I adjusted the /data/ mount at any point or deleted anything anywhere. The good news is that the ls command does list a suitably large database, which beats the pants out of not listing anything at all:


This makes me think the issue is not the backup, but rather Duplicati seeing the backup. I tried two different browsers on two different computers (Chrome Windows, Chrome MacOS, Safari MacOS), so I don’t think it’s obviously a Web UI issue.

So what might we try next? Appreciate your support so far.

Can you take a screen shot of the web UI? It is possible it’s not loading completely, and not showing jobs, etc. I have seen that on occasion. If you don’t see the word “Beta” (or “Canary” etc) under the Duplicati logo in the top left, and instead it’s blank, that’s a telltale sign:


1 Like

Hmmm, I see.

No Beta/Canary:

Checked JS Console and see some Angular errors:

I might have thought, okay, some browser extension is interfering, but when I open on a totally separate browser…
Screen Shot 2021-10-27 at 6.50.33 PM

… same angular errors in the JS console on that browser as well.

Tried force refresh, dump cache, different browser, and opening in Incognito. No love!

Can you try stopping and restarting the container (if you haven’t tried it already)? I sometimes have that issue on my NAS, not sure why.

1 Like

That fixed it. It’s bizarre, I have no idea why I didn’t try that before posting here, and I’m sorry for wasting your time. I still appreciate your help – because now I have a better idea of what to look for if there’s ever a next time. I am going to mark your post as a solution, but please let me know if there’s anything else I can do to show support for your kind and diligent attention here.

Glad that helped! And you aren’t wasting anyone’s time. It would be nice to figure out why the container sometimes doesn’t start properly!