Backend quota has been exceeded

I just reinstalled Duplicati and when running a backup to MS Onedrive, it says successful but then I get the following error:

2020-04-04 11:05:30 -05 - [Error-Duplicati.Library.Main.Operation.FilelistProcessor-BackendQuotaExceeded]: Backend quota has been exceeded: Using 2.01 GB of 931.32 GB (0 bytes available)

I’ve looked in this forum and see where others have had this problem but I haven’t seen how to resolve it. Any help would be appreciated.

Duplicati and Mac OS Catalina 10.15.4


Which if any of the numbers seem ballpark OK, e.g. according to Duplicati Home screen, and left side near bottom of where it says what’s used and what total available space is?

Sounds like there might be some prior backups. Was there a problem leading to the need to reinstall?

Viewing the log files of a backup job should then have some old logs. What is some history for these?


You possibly don’t have a log for the backup that raised the error, but if you got one, what does it say?
Does this message reoccur if you backup again? I think the quota testing runs before next backup too.

Thanks for the response. From the Home Screen:
Source: 2.00 GB - this looks correct as the size of the file being backed up.
Backup: 2.01 GB - this looks about right to me

Onedrive says 4.64 GB used of 100 GB

The reason for the reinstall was that the backup was failing and I had these errors each time I tried. After the reinstall it says the backup was successful but I still get the error.

Also, I just created a new backup to Box Drive and it ran without error.

The log that has an error says:
“TotalQuotaSpace”: 999995129856,
“FreeQuotaSpace”: 0,
“AssignedQuotaSpace”: -1

“RetryAttempts”: 0

The error for Onedrive has happened each time it was run manually from the UI or as scheduled.

Compare OneDrive plans shows a 100 GB plan, but also some 1000 GB (1 TB) Office 365 plans.
I mention their sizes because “TotalQuotaSpace”: 999995129856 is 1 TB. Which are you buying?

It sounds like Duplicati’s counting is about right, but something is way off with OneDrive’s number.
The 0 seems wrong, and I’m wondering what the total is supposed to be (factor of 10 differences).

If you have backup logs from before the problem began, what sort of Total and Free do they give?
While surveying old logs, also keep an eye out for RetryAttempts. Lots of those might be an issue.

Duplicati.CommandLine.BackendTester.exe turns out to have a quota reader at the end of its test:

Checking quota...
Free Space:  22.90 GB
Total Space: 25.00 GB

It takes an empty folder which you point to with a URL similar to what Export As Command-line has.
For a shorter test, you can give it something like --reruns=1 to get it to get to the quota a little faster.

Although this is still Duplicati code, it’s a simpler environment than the full program, so it might differ.
If macOS won’t run the .exe directly, you can probabably run it by adding mono before the command.

There are probably some third-party programs that can get the quota, but one would have to search.
If the problem is actually OneDrive returning it wrong (not proven yet), it will be hard to work around.


The backup Destination is now Storage type Microsoft OneDrive v2, not Local folder, right?
Using a file sync protocol sort of works, but would be a completely different exercise in quota debug.

I did have MS Office 365 with 1TB Onedrive storage but I discontinued it and now have a 100GB plan.

I was not able to run the Tester command from the Mac terminal. I think because it doesn’t like .exe with or without mono or mono. in the front. I tried to look for Total Quota for Onedrive but don’t know how to get it. I can try through MS support or try to find a third party option.

Edit: After I’d posted this I created another backup on Google Drive and it also had the same error as with Onedrive. It says it ran successfully but it gave the same error and the log looked the same as with the Onedrive backup.

This morning the Onedrive and Google Drive backups ran successfully but both received the same error about the Quota being exceeded. Their error logs looked the same for TotalQuotaSpace, FreeQuotaSpace and Retries.

The backup to Box Drive succedded without error.

I then did a successful restore from Onedrive but it also gave the Quota exceeded error:
2020-04-06 10:43:02 -05 - [Error-Duplicati.Library.Main.Operation.FilelistProcessor-BackendQuotaExceeded]: Backend quota has been exceeded: Using 2.01 GB of 233.47 GB (0 bytes available)

The restored files all seem to be good so it looks like things are working even with the errors.

The job of mono is to run the .exe and .dll files which in this case are portable code, not Windows code.
Application Deployment explains. If you can run mono at all, run mono --version. You need at least 5.
If mono can’t find the .exe, it’s possibly because I forgot to tell you you should either cd or use full path.

It turned out to be quite hard for me (without a Mac) to figure out where things are, but here’s one view. Yours (seen through the ps command, maybe something like ps -auxf | grep mono) may be similar. You can see there how mono is launched, and given a .exe to run. Other .exe files are in the folder too.

I’m also still trying to confirm that you’re going directly to OneDrive, and that your Destination looks like:


I’m still also looking for space history from jobs before the problem rose, to see how it looked back then. Suddenly seeing different results without Duplicati changes would suggest that OneDrive changed then. Possibly this also matches when you changed your size to 100 GB. I don’t know why 999995129856 is still being reported by OneDrive, and I doubt Duplicati made it up – it’s an odd value. How far back is it?

I did not have MS OneDrive Vs as storage type, I had “local file or drive”. I changed it to Microsoft OneDrive V2 and got the auth key. When I ran it it failed with the following message:

Error while running OneDrive Backup. Found 91 files that are missing from the remote storage, please run repair.

I tried to run Repair but nothing happened.

I also had “local file or drive” for the Google Storage Type. When I changed it to Google Drive I got the same error as with OneDrive except it was 85 missing files.

OK, I think I have things working now.
I updated to the latest mono
I deleted all backup files from both Onedrive and Google Drive
I deleted existing OneDrive and Google Drive Duplicati backups.

I recreated new backups with the Source Data corrected to Microsoft OneDrive V2 and Google Drive in Duplicati and they both ran without error.

The only thing now is I get Cert warnings and even after entering the commands recommended, it doesn’t seem to stop the warnings.

I will contine to test some restores but I think I’m good for now.

Thanks very much for all the help.

I’m glad you got it going. I don’t know what’s up with missing files. In theory, anything Duplicati does to the local filesystem should eventually get synced to the remote, but one loses the better tracking done by Duplicati. One can even get files uploaded in unknown order chosen by the sync software. This can leave who-knows-what on the remote to restore from if the local drive breaks before finishing the sync.

Knowing you were pointing to a local folder means this is possibly a seeming bug in mono described at

Backend quota has been exceeded after apparently successful backup
Warning Backend quota is close to being exceeded

Possibly your quota information came from a local filesystem (I can’t explain in detail). Maybe try df -k?

Secure Socket Layer (SSL) / Transport Layer Security (TLS) is good for troubleshooting certificate fails.
If you’re missing ca-certificates, and don’t want to get it separately, I think mono-complete includes that.