Backblaze B2 on Linux?

Hello, I’m new to both Duplicati and Backblaze… another refugee from Crashplan.

Is Duplicati on Linux currently working with Backblaze B2? I have a home file server running Mint 18.2 where I installed Duplicati I was able to successfully set up a backup to a remote SFTP server, but am having issues connecting to Backblaze B2. I tried setting up a backup to Backblaze B2 on my Windows 10 desktop with Duplicati, and everything works exactly as expected.

I can and will provide any additional info to help troubleshoot this. I just wanted to ask first if Backblaze B2 is actually supported with Duplicati on Linux before wading in deeper. I mainly came to Duplicati because it’s mentioned at the bottom of Backblaze’s how-to for configuring Duplicity on Linux.

This is the first time i’m hearing of any issue with B2 and linux (disclaimer: i haven’t run it myself, though I use both on Windows). What happens when you try?

I did an very small test with my linux box around late August no issues with B2. Don’t actively use it as source so I will have to check to see if it still working.

That was fast…

The first time I hit test connection I get:

Failed to connect: The server certificate had the error RemoteCertificateChainErrors and the hash XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX If you trust this certificate, use the commandline option --accept-specified-ssl-hash=XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX to accept the server certificate anyway. You can also attempt to import the server certificate into your operating systems trust pool. You may want to import a set of trusted certificates into the Mono certificate store. Use the command: cert-sync /etc/ssl/certs/ca-certificates.crt #for Debian based systems cert-sync /etc/pki/tls/certs/ca-bundle.crt #for RedHat derivatives Read more: Release Notes Mono 3.12.0 | Mono

I found --accept-specified-ssl-hash in the advanced options, but with or without the hash, I always get “Failed to connect: GetResponse timed out” on subsequent tries.

On windows, I get no error messages at all - it just works first try.


You need to install the ca-certificates-mono package, otherwise it does not have the SSL CA certificates required to validate the connection: SSL TLS support in Mono · duplicati/duplicati Wiki · GitHub

I figured I’d try it out on my VM mint install – so now I’ve been all through that, and tried various things, and still have no idea what i’m doing wrong (Mint 17).

The latest I get when trying to install Mono Certificates is this:

Ok, that makes sense after reading the error message again. I tried the ‘cert-sync’ command and it was not installed. After installing ca-certificates-mono package, I initially got the same message “Failed to connect: GetResponse timed out”. I ended up deleting my backup config in Dupicati, stopped and restarted Duplicati, then made a new bucket in B2. Now it works great. Running my first backup to B2 now. Thank you for your help!

drakar2007: Some of the following has helped me out of that situation in the past:

apt-get update
apt-get upgrade
apt-get dist-upgrade
apt-get install -f
apt-get clean
apt-get autoclean
apt-get autoremove
dpkg --configure -a

1 Like

This seems to happen fairly often - I know the About page of the GUI includes the mono version - is there a way to test if ca-certificates-mono package is installed (or stale) and if the user selects a destination that uses SSL let them know they may need to update?

1 Like

I eventually got it working - the trick was following the install instructions here, but also actually using my correct ubuntu version (i’m on mint 17.1 so ubuntu 14.04). It started working right away after that.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.

It happens because the Mono package is part of Debian/Ubuntu, so most people do apt-get install mono and get a really old version. Then they have trouble getting the latest version from Xamarin installed, and this more problems.

If you start with the Xamarin version, everything works, and it should include ca-certificates-mono (or at least run cert-sync automatically).

Updating the Debian/Ubuntu repo would be the right way to fix it, but they are not moving that fast :slight_smile:

Yep - that happens, as we all know. :wink:

I guess I’m just thinking that if we know this is an issue with certain distros, is there some way we can pro-actively deal with it it such as:

  • checking (and alerting about) cert levels during Duplicati installation
  • checking (and alerting about) cert levels during applicable destination configuration
  • catching this error and checking cert levels with a more user friendly “hey, your certificates seem out of date, try installing ca-certificates-mono to fix it” type message

The current approach is to see if there are any certificates installed at all. If this is not the case it will prompt the user to run cert-sync.

But we could also just give a special message if the current Mono version is less than 5.0.

1 Like